diff mbox series

[bug#73520,2/2] gnu: xdg-desktop-portal: Update to 1.18.4.

Message ID 4d6858377ab01fff649eb70b92e01cafe4b42ab0.1727461684.git.rodion.goritskov@gmail.com
State New
Headers show
Series Potential fix for the latest xdg-desktop-portal | expand

Commit Message

Rodion Goritskov Sept. 28, 2024, 7:41 a.m. UTC
* gnu/packages/freedesktop.scm (xdg-desktop-portal): Update to 1.18.4.
* gnu/packages/telegram.scm (telegram-desktop): Change native-input to xdg-desktop-portal.

Change-Id: I25ac64ce62f994e1e2cffbdbd8e8a7779a6b9658
---
 gnu/packages/freedesktop.scm | 78 ++++++++++++------------------------
 gnu/packages/telegram.scm    |  2 +-
 2 files changed, 26 insertions(+), 54 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 73bd5c8a3d..f86c611c57 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3012,7 +3012,7 @@  (define-public libportal
 (define-public xdg-desktop-portal
   (package
     (name "xdg-desktop-portal")
-    (version "1.16.0")
+    (version "1.18.4")
     (source
      (origin
        (method url-fetch)
@@ -3021,30 +3021,34 @@  (define-public xdg-desktop-portal
              version "/xdg-desktop-portal-" version ".tar.xz"))
        (sha256
         (base32
-         "06cczlh39kc41rvav06v37sad827y61rffy3v29i918ibj8sahav"))))
-    (build-system gnu-build-system)
+         "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
+       (patches (search-patches
+                 "xdg-desktop-portal-disable-portal-tests.patch"
+                 "xdg-desktop-portal-disable-configuration-search-exit.patch"))))
+    (build-system meson-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("glib:bin" ,glib "bin")
-       ("which" ,which)
-       ("gettext" ,gettext-minimal)))
+     (list pkg-config
+           `(,glib "bin")
+           gettext-minimal
+           python
+           python-dbusmock
+           python-pytest
+           python-pytest-xdist))
     (inputs
-     `(("gdk-pixbuf" ,gdk-pixbuf)
-       ("glib" ,glib)
-       ("flatpak" ,flatpak)
-       ("fontconfig" ,fontconfig)
-       ("json-glib" ,json-glib)
-       ("libportal" ,libportal)
-       ("dbus" ,dbus)
-       ("geoclue" ,geoclue)
-       ("pipewire" ,pipewire)
-       ("fuse" ,fuse)))
+     (list bubblewrap
+           gdk-pixbuf
+           glib
+           flatpak
+           fontconfig
+           json-glib
+           libportal
+           dbus
+           geoclue
+           pipewire
+           fuse))
     (arguments
      `(#:configure-flags
-       (list "--with-systemd=no")
+       (list "-Dsystemd=disabled")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'po-chmod
@@ -3073,38 +3077,6 @@  (define-public xdg-desktop-portal
 and others.")
     (license license:lgpl2.1+)))
 
-(define-public xdg-desktop-portal-next
-  (package
-    (inherit xdg-desktop-portal)
-    (version "1.18.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/flatpak/xdg-desktop-portal/releases/download/"
-             version "/xdg-desktop-portal-" version ".tar.xz"))
-       (sha256
-        (base32
-         "0r8y8qmzcfj7b7brqcxr9lg8pavfds815ffvj0kqc378fhgaln5q"))
-       (patches (search-patches
-                 "xdg-desktop-portal-disable-portal-tests.patch"
-                 "xdg-desktop-portal-disable-configuration-search-exit.patch"))))
-    (build-system meson-build-system)
-    (arguments
-     (substitute-keyword-arguments (package-arguments xdg-desktop-portal)
-       ((#:configure-flags _ ''())
-        #~(list "-Dsystemd=disabled"))))
-    (native-inputs
-     (list pkg-config
-           `(,glib "bin")
-           gettext-minimal
-           python
-           python-dbusmock
-           python-pytest
-           python-pytest-xdist))
-    (inputs (modify-inputs (package-inputs xdg-desktop-portal)
-              (prepend bubblewrap)))))
-
 (define-public xdg-desktop-portal-gtk
   (package
     (name "xdg-desktop-portal-gtk")
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index cfcd92fcbc..c0b2122bf5 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -537,7 +537,7 @@  (define-public telegram-desktop
            `(,gtk+ "bin")
            pkg-config
            python-wrapper
-           xdg-desktop-portal-next))
+           xdg-desktop-portal))
     (inputs
      (list abseil-cpp-cxxstd17
            alsa-lib