diff mbox series

[bug#69964,3/4] gnu: Add go-github-com-multiformats-multibase.

Message ID 69ebf5f71d88611591efddc00ce3c619203bb4a4.1711197915.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-multiformats-go-multibase. | expand

Commit Message

Artyom V. Poptsov March 23, 2024, 12:53 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-multiformats-multibase): New
  variable.

Change-Id: I5994e8f8927d5365cc201da30bd49abf03d17574
---
 gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c5851cfa5f..d7fd50ae3d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1413,6 +1413,33 @@  (define-public go-github-com-multiformats-go-base36
      "Optimized codec for @code{[]byte} <=> @code{base36} string conversion.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public go-github-com-multiformats-multibase
+  (let ((commit "4c8344e37852773de155f587dcf5897771b3fc19")
+        (revision "1"))
+    (package
+      (name "go-github-com-multiformats-multibase")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/multiformats/multibase")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0lz4kdysa6nx7wf1i59647w7dgm344xpvfnsac3pfk2qdky2kq8b"))))
+      (build-system copy-build-system)
+      (arguments
+       '(#:install-plan
+         '(("." "share/multibase/"))))
+      (home-page "https://github.com/multiformats/multibase")
+      (synopsis "Self identifying base encodings")
+      (description
+       "Multibase is a protocol for disambiguating the encoding of
+base-encoded (e.g., @code{base32}, @code{base36}, @code{base64}, @code{base58}, etc.)
+binary appearing in text.")
+      (license (list license:expat license:cc-by-sa3.0)))))
+
 (define-public go-github-com-multiformats-go-varint
   (package
     (name "go-github-com-multiformats-go-varint")