diff mbox series

[bug#69964,2/4] gnu: Add go-github-com-multiformats-go-base36.

Message ID 4d2be049a308fc13b88f0b4a61d4cc4242b5b2fd.1711197915.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-multiformats-go-multibase. | expand

Commit Message

Artyom V. Poptsov March 23, 2024, 12:53 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-multiformats-go-base36): New
  variable.

Change-Id: I27c5540fddae55ae9ce12a205d6f7f7c9a01569b
---
 gnu/packages/golang-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 5674004424..c5851cfa5f 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1390,6 +1390,29 @@  (define-public go-github-com-multiformats-go-base32
      "@code{base32} encoding package from Go with @code{NoPadding} option")
     (license license:bsd-3)))
 
+(define-public go-github-com-multiformats-go-base36
+  (package
+    (name "go-github-com-multiformats-go-base36")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/multiformats/go-base36")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1wfhsmxkvm97pglfwgiw3ad5g9vqc9nhd61i0kyvsb9lc006g8qq"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/multiformats/go-base36"))
+    (home-page "https://github.com/multiformats/go-base36")
+    (synopsis "Optimized @code{base36} codec for Go")
+    (description
+     "Optimized codec for @code{[]byte} <=> @code{base36} string conversion.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public go-github-com-multiformats-go-varint
   (package
     (name "go-github-com-multiformats-go-varint")