diff mbox series

[bug#67592,07/14] gnu: rust-indexmap: Update to 2.1.0.

Message ID 678d5ffa2649ed91ad015c18e676cbdd6d5bc146.1701551502.git.rteissier.code@chillpc.fr
State New
Headers show
Series gnu: rust-git2: Update to 0.18.1 | expand

Commit Message

RĂ©mi Teissier Dec. 2, 2023, 9:33 p.m. UTC
Change-Id: Icae0b1bc04bb5ff2ed50984a8b21591ff0ac060c
---
 gnu/packages/crates-io.scm | 48 +++++++++++++++++++-------------------
 1 file changed, 24 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7794ecf89a..35e0c050c9 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33805,32 +33805,32 @@  (define-public rust-indenter-0.3
 (define-public rust-indexmap-2
   (package
     (name "rust-indexmap")
-    (version "2.0.0")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "indexmap" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0pdnbvv6gnyxx2li8mks8p00fya3ynmhx3n6infpcy8a4gi7yiym"))))
+    (version "2.1.0")
+    (source
+      (origin
+         (method url-fetch)
+         (uri (crate-uri "indexmap" version))
+         (file-name (string-append name "-" version ".tar.gz"))
+         (sha256
+           (base32 "07rxrqmryr1xfnmhrjlz8ic6jw28v6h5cig3ws2c9d0wifhy2c6m"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
-       (("rust-arbitrary" ,rust-arbitrary-1)
-        ("rust-equivalent" ,rust-equivalent-1)
-        ("rust-hashbrown" ,rust-hashbrown-0.14)
-        ("rust-quickcheck" ,rust-quickcheck-1)
-        ("rust-rayon" ,rust-rayon-1)
-        ("rust-rustc-rayon" ,rust-rustc-rayon-0.5)
-        ("rust-serde" ,rust-serde-1))
-       #:cargo-development-inputs
-       (("rust-fnv" ,rust-fnv-1)
-        ("rust-fxhash" ,rust-fxhash-0.2)
-        ("rust-itertools" ,rust-itertools-0.10)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-quickcheck" ,rust-quickcheck-1)
-        ("rust-rand" ,rust-rand-0.8)
-        ("rust-serde-derive" ,rust-serde-derive-1))))
+      `(#:cargo-inputs
+        (("rust-serde" ,rust-serde-1)
+         ("rust-rustc-rayon" ,rust-rustc-rayon-0.5)
+         ("rust-rayon" ,rust-rayon-1)
+         ("rust-quickcheck" ,rust-quickcheck-1)
+         ("rust-arbitrary" ,rust-arbitrary-1)
+         ("rust-hashbrown" ,rust-hashbrown-0.14)
+         ("rust-equivalent" ,rust-equivalent-1))
+        #:cargo-development-inputs
+        (("rust-serde-derive" ,rust-serde-derive-1)
+         ("rust-rand" ,rust-rand-0.8)
+         ("rust-quickcheck" ,rust-quickcheck-1)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-itertools" ,rust-itertools-0.11)
+         ("rust-fxhash" ,rust-fxhash-0.2)
+         ("rust-fnv" ,rust-fnv-1))))
     (home-page "https://github.com/bluss/indexmap")
     (synopsis "Hash table with consistent order and fast iteration")
     (description