diff mbox series

[bug#67592,08/14] gnu: Add rust-syntect.

Message ID 00940d67be624dd7b700f6f24d70baa9cfb38920.1701551503.git.rteissier.code@chillpc.fr
State New
Headers show
Series gnu: rust-git2: Update to 0.18.1 | expand

Commit Message

RĂ©mi Teissier Dec. 2, 2023, 9:33 p.m. UTC
Change-Id: I5c6ef2044f6a39e88d9ecc6f64d35117d5791aae
---
 gnu/packages/crates-io.scm | 42 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 35e0c050c9..4123a1235e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -71047,6 +71047,48 @@  (define-public rust-syn-test-suite-0.0.0
     (description "Test suite of the syn crate.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-syntect-5
+  (package
+    (name "rust-syntect")
+    (version "5.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "syntect" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "14cg314vzabi45cdbqgcpav0dlx3d18blp24n3z8pl7q7cq4naz0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-yaml-rust" ,rust-yaml-rust-0.4)
+                       ("rust-regex-syntax" ,rust-regex-syntax-0.7)
+                       ("rust-plist" ,rust-plist-1)
+                       ("rust-onig" ,rust-onig-6)
+                       ("rust-fnv" ,rust-fnv-1)
+                       ("rust-flate2" ,rust-flate2-1)
+                       ("rust-fancy-regex" ,rust-fancy-regex-0.11)
+                       ("rust-bincode" ,rust-bincode-1)
+                       ("rust-walkdir" ,rust-walkdir-2)
+                       ("rust-thiserror" ,rust-thiserror-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-bitflags" ,rust-bitflags-1))
+       #:cargo-development-inputs (("rust-regex" ,rust-regex-1)
+                                   ("rust-rayon" ,rust-rayon-1)
+                                   ("rust-pretty-assertions" ,rust-pretty-assertions-0.6)
+                                   ("rust-getopts" ,rust-getopts-0.2)
+                                   ("rust-criterion" ,rust-criterion-0.3))))
+    (home-page "https://github.com/trishume/syntect")
+    (synopsis
+     "Library for high quality syntax highlighting and code intelligence using Sublime Text's grammars")
+    (description
+     "syntect is a syntax highlighting library for Rust that uses Sublime Text syntax
+definitions. It aims to be a good solution for any Rust project that needs syntax highligting,
+including deep integration with text editors written in Rust.")
+    (license license:expat)))
+
 (define-public rust-synchronoise-1
   (package
     (name "rust-synchronoise")