diff mbox series

[bug#67950,v3,1/3] gnu: Add inform.

Message ID 672f883c-b530-af90-673c-85d78b705583@disroot.org
State New
Headers show
Series [bug#67950,v3,1/3] gnu: Add inform. | expand

Commit Message

Adam Faiz Dec. 25, 2023, 12:16 a.m. UTC
From eea4385fef9805fd37517b476b8d581d081cc44c Mon Sep 17 00:00:00 2001
Message-ID: <eea4385fef9805fd37517b476b8d581d081cc44c.1703463244.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 21 Dec 2023 18:15:41 +0800
Subject: [PATCH v3 1/3] gnu: Add inform.

* gnu/packages/game-development.scm (inform): New variable.
---
 gnu/packages/game-development.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 29c94dd522833b2603a651c14a5b06120bcf1829
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a2d7c5ea63..0b2c0177ab 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2771,6 +2771,31 @@  (define-public ioquake3
 people base their games, ports to new platforms, and other projects.")
       (license license:gpl2))))
 
+(define-public inform
+  (let ((commit "20cbfff96015938809d0e3da6cd0d83b76d27f14")
+        (revision "0"))
+  (package
+    (name "inform")
+    (version (git-version "6.41" revision commit))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://jxself.org/git/inform.git")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "19z8pgrj1s2irany5s6xxwsm3bdnri1as46fdi16zdp4aah523jy"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf automake))
+    (synopsis "The Inform 6 compiler")
+    (description
+     "Inform 6 is a programming language designed for interactive fiction.
+This version of the compiler has been modified slightly to work better when the
+Inform standard library is in a non-standard location.")
+    (home-page "https://jxself.org/git/inform.git")
+    (license license:gpl3+))))
+
 (define-public instead
   (package
     (name "instead")