diff mbox series

[bug#67950,v3,2/3] gnu: Add informlib.

Message ID 542974c4-0804-4f8c-2302-c83db4fe7d75@disroot.org
State New
Headers show
Series [bug#67950,v3,1/3] gnu: Add inform. | expand

Commit Message

Adam Faiz Dec. 25, 2023, 12:17 a.m. UTC
From 017efac401edf8b4a1c60bfac11fb6c3467ee998 Mon Sep 17 00:00:00 2001
Message-ID: <017efac401edf8b4a1c60bfac11fb6c3467ee998.1703463244.git.adam.faiz@disroot.org>
In-Reply-To: <eea4385fef9805fd37517b476b8d581d081cc44c.1703463244.git.adam.faiz@disroot.org>
References: <eea4385fef9805fd37517b476b8d581d081cc44c.1703463244.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 24 Dec 2023 23:14:31 +0800
Subject: [PATCH v3 2/3] gnu: Add informlib.

* gnu/packages/game-development.scm (informlib): New variable.
---
 gnu/packages/game-development.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 0b2c0177ab..1eeaab097a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -57,6 +57,7 @@  (define-module (gnu packages game-development)
   #:use-module (guix svn-download)
   #:use-module (guix utils)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
@@ -2796,6 +2797,30 @@  (define-public inform
     (home-page "https://jxself.org/git/inform.git")
     (license license:gpl3+))))
 
+(define-public informlib
+  (package
+    (name "informlib")
+    (version "6.12.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://jxself.org/git/informlib.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fcnw4jjzln402qk097n2s8y24vw1p3mmlmh6k1mbr2zfajjcn5r"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:install-plan
+      #~'(("." "lib"))))
+    (synopsis "Inform 6 standard library")
+    (description
+     "This package provides the standard library for Inform 6.")
+    (home-page "https://jxself.org/git/informlib.git")
+    (license license:agpl3+)))
+
 (define-public instead
   (package
     (name "instead")