diff mbox series

[bug#65367,v3,2/4] gnu: Add python-pymarshal.

Message ID 6669d51237ca582be587698c8c015cd5b539b833.1698771987.git.sughosha@disroot.org
State New
Headers show
Series gnu: Add stargate | expand

Commit Message

Sughosha Oct. 31, 2023, 5:08 p.m. UTC
* gnu/packages/python-xyz.scm (python-pymarshal): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 53e57f8b49..205691f46a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31198,6 +31198,28 @@  (define-public python-peachpy
 supports x86_64 instructions up to AVX-512 and SHA.")
       (license license:bsd-2))))
 
+(define-public python-pymarshal
+  (package
+    (name "python-pymarshal")
+    (version "2.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pymarshal" version))
+              (sha256
+               (base32
+                "1lhb7yim60pvclbd440zd4n50xs1d2rvmnrhhvib3hyv0dxil5j3"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:tests? #f)) ;fails due to unrecognized arguments
+    (native-inputs
+     (list python-pytest))
+    (propagated-inputs (list python-bson python-pyyaml))
+    (home-page "https://gitlab.com/d3v-t00lz/pymarshal")
+    (synopsis "Pythonic implementation of Golang struct (un)marshalling")
+    (description "PyMarshal replicates the feature of (un)marshalling structs
+in Golang.")
+    (license license:bsd-2)))
+
 (define-public python-sgmllib3k
   (let ((commit "799964676f35349ca2dd04503e34c2b3ad522c0d")
         (revision "1"))