diff mbox series

[bug#65367,v3,3/4] gnu: Add python-mido.

Message ID 5d406e16ba881087e1297efdad6cb2d66739395e.1698771987.git.sughosha@disroot.org
State New
Headers show
Series gnu: Add stargate | expand

Commit Message

Sughosha Oct. 31, 2023, 5:08 p.m. UTC
* gnu/packages/python-xyz.scm (python-mido): New variable.
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 205691f46a..0864f284e1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23363,6 +23363,29 @@  (define-public python-pydub
 @code{ffmpeg} to open various audio formats.")
     (license license:expat))) ; MIT license
 
+(define-public python-mido
+  (package
+    (name "python-mido")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "mido" version))
+              (sha256
+               (base32
+                "1al6r86pa0700862cm5qmzz5q94qrgdv4392hkws7g1lrqx2wa44"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (delete 'sanity-check)))) ;fails
+    (propagated-inputs (list python-importlib-metadata python-packaging))
+    (native-inputs (list python-pytest))
+    (home-page "https://mido.readthedocs.io/en/stable/")
+    (synopsis "MIDI Objects for Python")
+    (description "This library is for working with MIDI 1.0 ports, messages and
+files.")
+    (license license:expat)))
+
 (define-public python-tqdm
   (package
     (name "python-tqdm")