diff mbox series

[bug#64875,3/4] gnu: Added xsv.

Message ID 6489b19de7908f5bd88b4bcd41cfeba27e92fc03.1690386417.git.w@wmeyer.eu
State New
Headers show
Series Adding xsv | expand

Commit Message

Wilko Meyer July 26, 2023, 3:52 p.m. UTC
* added xsv to rust-apps.scm
---
 gnu/packages/rust-apps.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 8c29969712..2762d6186a 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2362,3 +2362,38 @@  (define-public htmlq
     (synopsis "Like jq, but for HTML")
     (description "Extract content from HTML files using CSS selectors.")
     (license license:expat)))
+
+(define-public xsv
+  (package
+    (name "xsv")
+    (version "0.13.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "xsv" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0pvzr7x5phlya6m5yikvy13vgbazshw0plysckz9zmf2ly5x4jl8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+                       ("rust-chan" ,rust-chan-0.1)
+                       ("rust-csv" ,rust-csv-1)
+                       ("rust-csv-index" ,rust-csv-index-0.1)
+                       ("rust-docopt" ,rust-docopt-1)
+                       ("rust-filetime" ,rust-filetime-0.1)
+                       ("rust-num-cpus" ,rust-num-cpus-1)
+                       ("rust-rand" ,rust-rand-0.4)
+                       ("rust-regex" ,rust-regex-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-derive" ,rust-serde-derive-1)
+                       ("rust-streaming-stats" ,rust-streaming-stats-0.2)
+                       ("rust-tabwriter" ,rust-tabwriter-1)
+                       ("rust-threadpool" ,rust-threadpool-1))
+       #:cargo-development-inputs (("rust-log" ,rust-log-0.4)
+                                   ("rust-quickcheck" ,rust-quickcheck-0.6))))
+    (home-page "https://github.com/BurntSushi/xsv")
+    (synopsis "High performance CSV command line toolkit")
+    (description
+     "This package provides a high performance CSV command line toolkit.")
+    (license (list license:unlicense license:expat))))