diff mbox series

[bug#65428,1/3] gnu: Add r-maptree.

Message ID 644667be3cab344a644978979696edd10c45ae03.1692625477.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#65428,1/3] gnu: Add r-maptree. | expand

Commit Message

nafkhamdc Aug. 21, 2023, 1:44 p.m. UTC
* gnu/packages/statistics.scm (r-maptree): New variable.
---
 gnu/packages/statistics.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 3c6b6941a2c76c26ebf0c1bfd7f901a22c19dce1

Comments

Ricardo Wurmus Aug. 28, 2023, 7:55 a.m. UTC | #1
Applied with changes to the description (to use complete sentences) and
to the license comment.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 5abc62d760..41243ca7a7 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -433,6 +433,28 @@  (define r-with-tests
 available, greatly increasing its breadth and scope.")
     (license license:gpl3+)))
 
+(define-public r-maptree
+  (package
+    (name "r-maptree")
+    (version "1.4-8")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "maptree" version))
+              (sha256
+               (base32
+                "1x35nk4fi2b62krcvcv187n5sbqrgvw4pbm7r19ps3jlanpi5ksm"))))
+    (properties `((upstream-name . "maptree")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-cluster r-rpart))
+    (home-page "https://cran.r-project.org/package=maptree")
+    (synopsis "Mapping, pruning, and graphing tree models")
+    (description
+     "Set of functions with example data for graphing, pruning, and mapping models.
+These moldes are from hierarchical clustering, and classification and
+regression trees.")
+    ;; Custom license, see https://cran.r-project.org/web/packages/maptree/index.html
+    (license (license:non-copyleft "file://DESCRIPTION"))))
+
 (define-public r-minimal
   (package (inherit r-with-tests)
     (name "r-minimal")