diff mbox series

[bug#65429,3/3] gnu: Add r-tgp.

Message ID 37e9e5f9dbdc86b9fc6ad2dad03ee832f3b029e5.1692625478.git.navid.afkhami@mdc-berlin.de
State New
Headers show
Series [bug#65428,1/3] gnu: Add r-maptree. | expand

Commit Message

nafkhamdc Aug. 21, 2023, 1:44 p.m. UTC
* gnu/packages/cran.scm (r-tgp): New variable.
---
 gnu/packages/cran.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Ricardo Wurmus Aug. 28, 2023, 7:58 a.m. UTC | #1
Applied with minor changes.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 08e206673c..cf2e2e1f59 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1059,6 +1059,29 @@  (define-public r-googlesheets4
 can read and write both the metadata and the cell data in a Sheet.")
     (license license:expat)))
 
+(define-public r-tgp
+  (package
+    (name "r-tgp")
+    (version "2.4-21")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "tgp" version))
+              (sha256
+               (base32
+                "12ifd7rm3wskhbpnhfvz92z3graxzryq0iy1jiqmdk6bvhxkiww8"))))
+    (properties `((upstream-name . "tgp")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-maptree))
+    (home-page "https://bobby.gramacy.com/r_packages/tgp/")
+    (synopsis "Bayesian treed gaussian process Models")
+    (description
+     "R-tgb provides Bayesian nonstationary regression and treed Gaussian processes.
+Iin addition, it  provides visualization functions, tree drawing, sensitivity
+analysis, multi-resolution models, and sequential experimental design tools,
+including ALM, ALC, and expected improvement for optimizing noisy black-box
+functions.")
+    (license license:lgpl2.0+)))
+
 (define-public r-pma
   (package
     (name "r-pma")