diff mbox series

[bug#51358,1/4] gnu: Add ocaml-lacaml.

Message ID 6309f0761c6c6eb56e103a12f8265f3f5bed5cbd.1635199548.git.julien@lepiller.eu
State Accepted
Headers show
Series [bug#51358,1/4] gnu: Add ocaml-lacaml. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Julien Lepiller Oct. 25, 2021, 10:06 p.m. UTC
* gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
(ocaml-lacaml): ...this.  Use latest ocaml package.
---
 gnu/packages/ocaml.scm | 15 ++++++---------
 1 file changed, 6 insertions(+), 9 deletions(-)

Comments

Simon Tournier Oct. 27, 2021, 1:39 p.m. UTC | #1
Hi Julien

On mar., 26 oct. 2021 at 00:06, Julien Lepiller <julien@lepiller.eu> wrote:
> * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
> (ocaml-lacaml): ...this.  Use latest ocaml package.
> ---
>  gnu/packages/ocaml.scm | 15 ++++++---------
>  1 file changed, 6 insertions(+), 9 deletions(-)

LGTM.


However, I am not able to apply the rest of the serie.  Probably because
of the base-commit.  Against which commit, do your patches apply?

I wanted to build them before saying that LGTM -- although at first
sight, they look good to me. :-)


Cheers,
simon
Julien Lepiller Oct. 27, 2021, 3:27 p.m. UTC | #2
Le 27 octobre 2021 09:39:48 GMT-04:00, zimoun <zimon.toutoune@gmail.com> a écrit :
>Hi Julien
>
>On mar., 26 oct. 2021 at 00:06, Julien Lepiller <julien@lepiller.eu> wrote:
>> * gnu/packages/ocaml.scm (ocaml4.07-lacaml): Replace with...
>> (ocaml-lacaml): ...this.  Use latest ocaml package.
>> ---
>>  gnu/packages/ocaml.scm | 15 ++++++---------
>>  1 file changed, 6 insertions(+), 9 deletions(-)
>
>LGTM.
>
>
>However, I am not able to apply the rest of the serie.  Probably because
>of the base-commit.  Against which commit, do your patches apply?
>
>I wanted to build them before saying that LGTM -- although at first
>sight, they look good to me. :-)
>
>
>Cheers,
>simon

Ha, I built that series on top of previous (unrelated) patches: #51351 and #51356
Simon Tournier Nov. 15, 2021, 1:10 p.m. UTC | #3
Hi Julien,

On Wed, 27 Oct 2021 at 11:27, Julien Lepiller <julien@lepiller.eu> wrote:

>>However, I am not able to apply the rest of the serie.  Probably because
>>of the base-commit.  Against which commit, do your patches apply?
>>
>>I wanted to build them before saying that LGTM -- although at first
>>sight, they look good to me. :-)

[...]

> Ha, I built that series on top of previous (unrelated) patches: #51351 and #51356

Bah I still have some issue.  Probably because of base-commit.  From my
point of view, specifying “git format-patch --base=<commit>” where
<commit> is the last commit on the top of the branch against the series
applies help for synchronizing the Git tree since it moves really fast
these days. :-)  For instance, I use “--base=origin/master” is the
divergence starts there.

Anyway.  The series LGTM.


Cheers,
simon
Julien Lepiller Nov. 20, 2021, 6:56 p.m. UTC | #4
Pushed to master as e9d3f3656bd8a16deb1f643c9ed9f5706a6f9eaf to
0846e7d3265f9fc1b7d83676ef75c55f78faa587.

Now only three leaf packages are left: pplacer, bap and ocaml4.07-core.
I'll see what I can do. Removing the last one should be relatively
easy. Bap needs an update to 2.3.0 in addition to switching to
ocaml-4.11, but the update requires some more packages, so I'll need a
bit of time. pplacer is stuck, the version we have is not even
compatible with 4.07, but was heavily patched by Ricardo once. I'm
hoping for another miracle :)
Simon Tournier Nov. 22, 2021, 9:14 a.m. UTC | #5
Hi,

On Sat, 20 Nov 2021 at 19:56, Julien Lepiller <julien@lepiller.eu> wrote:

>              pplacer is stuck, the version we have is not even
> compatible with 4.07, but was heavily patched by Ricardo once. I'm
> hoping for another miracle :)

Why not simply remove 'pplacer' from master and move it to guix-past?


Cheers,
simon
Ricardo Wurmus Nov. 22, 2021, 7:40 p.m. UTC | #6
zimoun <zimon.toutoune@gmail.com> writes:

> Hi,
>
> On Sat, 20 Nov 2021 at 19:56, Julien Lepiller 
> <julien@lepiller.eu> wrote:
>
>>              pplacer is stuck, the version we have is not even
>> compatible with 4.07, but was heavily patched by Ricardo 
>> once. I'm
>> hoping for another miracle :)
>
> Why not simply remove 'pplacer' from master and move it to 
> guix-past?

I agree.  This is a good idea.
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f640acca35..65f311f9bf 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6757,7 +6757,7 @@  (define-public ocaml4.07-fftw3
        ("fftwf" ,fftwf)))
     (native-inputs
      `(("ocaml-cppo" ,(package-with-ocaml4.07 ocaml-cppo))
-       ("ocaml-lacaml" ,ocaml4.07-lacaml)))
+       ("ocaml-lacaml" ,(package-with-ocaml4.07 ocaml-lacaml))))
     (home-page
      "https://github.com/Chris00/fftw-ocaml")
     (synopsis
@@ -6767,10 +6767,10 @@  (define-public ocaml4.07-fftw3
 library FFTW.")
     (license license:lgpl2.1))) ; with static linking exception.
 
-(define-public ocaml4.07-lacaml
+(define-public ocaml-lacaml
   (package
-    (name "ocaml4.07-lacaml")
-    (version "11.0.5")
+    (name "ocaml-lacaml")
+    (version "11.0.8")
     (source
      (origin
        (method git-fetch)
@@ -6780,13 +6780,10 @@  (define-public ocaml4.07-lacaml
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "180yb79a3qgx067qcpm50q12hrimjygf06rgkzbish9d1zfm670c"))))
+         "115535kphchh2a434b48b408x9794j8zzrsdmacsgqdsrgy3rck4"))))
     (build-system dune-build-system)
     (arguments
-     `(#:tests? #f ; No test target.
-       #:ocaml ,ocaml-4.07
-       #:findlib ,ocaml4.07-findlib
-       #:dune ,ocaml4.07-dune))
+     `(#:tests? #f)) ; No test target.
     (native-inputs
      `(("openblas" ,openblas)
        ("lapack" ,lapack)