diff mbox series

[bug#67757,11/19] gnu: Add rust-grep-printer-0.2.

Message ID 593b3bbfe35c0eecdee5c6493bfad4bb8bd277ca.1702248678.git.jaeme@runbox.com
State New
Headers show
Series gnu: rust-apps: Update ripgrep to 14.0.3 | expand

Commit Message

Jaeme Sifat Dec. 10, 2023, 11:06 p.m. UTC
* gnu/packages/crates-io.scm (rust-grep-printer-0.2): New variable.

Change-Id: Ic830cbf5125f7419662d28cd61c28ae2da2082ab
---
 gnu/packages/crates-io.scm | 39 ++++++++++++++++++++++++++++++--------
 1 file changed, 31 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 22ee959e6a..f88d76bfe2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33716,8 +33716,38 @@  (define-public rust-grep-pcre2-0.1
     (description "Use PCRE2 with the grep crate.")
     (license (list license:expat license:unlicense))))
 
+(define-public rust-grep-printer-0.2
+  (package
+    (name "rust-grep-printer")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "grep-printer" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1cnf70gjnybfql0lmpr32dslb4xhxgc6h0dxwnv3ivla7jh14g3l"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+                       ("rust-grep-matcher" ,rust-grep-matcher-0.1)
+                       ("rust-grep-searcher" ,rust-grep-searcher-0.1)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-termcolor" ,rust-termcolor-1))
+       #:cargo-development-inputs
+       (("rust-grep-regex" ,rust-grep-regex-0.1))))
+    (home-page "https://github.com/BurntSushi/ripgrep")
+    (synopsis "Standard printing of search results")
+    (description
+     "This package is an implementation of the grep crate's Sink trait that
+provides standard printing of search results, similar to grep itself.")
+    (license (list license:unlicense license:expat))))
+
 (define-public rust-grep-printer-0.1
   (package
+    (inherit rust-grep-printer-0.2)
     (name "rust-grep-printer")
     (version "0.1.6")
     (source
@@ -33729,7 +33759,6 @@  (define-public rust-grep-printer-0.1
        (sha256
         (base32
          "0wnw8khcvris8canv1dp58qh6vph18fml9qsnrsmdpxf9ni73hh5"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-base64" ,rust-base64-0.13)
@@ -33741,13 +33770,7 @@  (define-public rust-grep-printer-0.1
         ("rust-serde-json" ,rust-serde-json-1)
         ("rust-termcolor" ,rust-termcolor-1))
        #:cargo-development-inputs
-       (("rust-grep-regex" ,rust-grep-regex-0.1))))
-    (home-page "https://github.com/BurntSushi/ripgrep")
-    (synopsis "Standard printing of search results")
-    (description
-     "This package is an implementation of the grep crate's Sink trait that
-provides standard printing of search results, similar to grep itself.")
-    (license (list license:unlicense license:expat))))
+       (("rust-grep-regex" ,rust-grep-regex-0.1))))))
 
 (define-public rust-grep-regex-0.1
   (package