diff mbox series

[bug#67757,14/19] gnu: rust-grep-pcre2-0.1: Update to 0.1.7.

Message ID 3ab75e1122e12567dd4ae255ff85a1ce2f20d021.1702248679.git.jaeme@runbox.com
State New
Headers show
Series gnu: rust-apps: Update ripgrep to 14.0.3 | expand

Commit Message

Jaeme Sifat Dec. 10, 2023, 11:06 p.m. UTC
* gnu/packages/crates-io.scm (rust-grep-pcre2-0.1): Update to 0.1.7.
[native-inputs]: Move pcre2 to inputs.
[home-page]: Update to exact location in git.

Change-Id: I9cff41ade41f1b3e54ddaf7ef059c1e3979d44b6
---
 gnu/packages/crates-io.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b200f4fc45..9336dbcfc0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33693,7 +33693,7 @@  (define-public rust-grep-matcher-0.1
 (define-public rust-grep-pcre2-0.1
   (package
     (name "rust-grep-pcre2")
-    (version "0.1.5")
+    (version "0.1.7")
     (source
      (origin
        (method url-fetch)
@@ -33702,16 +33702,16 @@  (define-public rust-grep-pcre2-0.1
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0hfyxsavqzf4rb5vc2a4hhi8dqw75vw1h95hinp4km9b6yxyvv66"))))
+         "1zwb5acalq7rvy70z4gsarqmrfaqmf9016yvxz5f573434idai02"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
-       (("rust-grep-matcher" ,rust-grep-matcher-0.1)
-        ("rust-pcre2" ,rust-pcre2-0.2))))
-    (native-inputs
-     (list pcre2 pkg-config))
+     `(#:cargo-inputs (("rust-grep-matcher" ,rust-grep-matcher-0.1)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-pcre2" ,rust-pcre2-0.2))))
+    (native-inputs (list pkg-config))
+    (inputs (list pcre2))
     (home-page
-     "https://github.com/BurntSushi/ripgrep")
+     "https://github.com/BurntSushi/ripgrep/tree/master/crates/pcre2")
     (synopsis "Use PCRE2 with the grep crate")
     (description "Use PCRE2 with the grep crate.")
     (license (list license:expat license:unlicense))))