diff mbox series

[bug#64338,RFC] gnu: ungoogled-chromium: Build with h264.

Message ID 587c8308f3fa585f5f93426e9d0b646170dfe4f0.1687978766.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#64338,RFC] gnu: ungoogled-chromium: Build with h264. | expand

Commit Message

Liliana Marie Prikler June 28, 2023, 6:57 p.m. UTC
* gnu/packages/chromium.scm (ungoogled-chromium)[configure-flags]: Change
“rtc_use_h264=false” to “rtc_use_h264=true”.
---
Hi Guix,

we haven't had a browser with a working WebRTC implementation for quite
some time now (basically, both icecat and ungoogled-chromium choke on
h264, which is very important for actually seeing video in video
conferences).  Looking at chromium in particular, the comment next to
the flag disabling this feature appears wrong/possibly outdated.
As far as I can tell, our ungoogling script already unbundles openh264,
so there is nothing to be afraid of.

WDYT?

BTW, it would of course be nice to have the same for icecat, and
possibly have a GStreamer-based WebRTC once GNOME browsers actually
come around to support this use case.  I simply looked at chromium
first because I recalled it to work perfectly fine before this flag
was added.

Cheers

@ mentors: Sorry to CC you all, but I really want at least 2 LGTMs
before pushig.

 gnu/packages/chromium.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: b24a05830d11e3011eee4bc5f60a41e26188cde1

Comments

Liliana Marie Prikler Sept. 9, 2023, 9:33 a.m. UTC | #1
Am Mittwoch, dem 28.06.2023 um 20:57 +0200 schrieb Liliana Marie
Prikler:
> * gnu/packages/chromium.scm (ungoogled-chromium)[configure-flags]:
> Change
> “rtc_use_h264=false” to “rtc_use_h264=true”.
> ---
Pushed a while ago, forgot to mark as done.
diff mbox series

Patch

diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index cef21a4fd1..6a9f113831 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -584,7 +584,7 @@  (define-public ungoogled-chromium
               "ffmpeg_branding=\"Chrome\""
 
               ;; WebRTC stuff.
-              "rtc_use_h264=false"      ;XXX needs bundled openh264
+              "rtc_use_h264=true"
               "rtc_use_pipewire=true"
               "rtc_link_pipewire=true"
               ;; Don't use bundled sources.