diff mbox series

[bug#58614,v2,066/192] gnu: Remove rust-argon2rs-0.2.

Message ID 561dea87407814900b0f338ad19e1d0f2668c9c9.1666519338.git.efraim@flashner.co.il
State New
Headers show
Series Remove unused crates | expand

Commit Message

Efraim Flashner Oct. 23, 2022, 10:02 a.m. UTC
* gnu/packages/crates-io.scm (rust-argon2rs-0.2): Delete variable.
---
 gnu/packages/crates-io.scm | 33 ---------------------------------
 1 file changed, 33 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bfecb37d15..782eddb4b1 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3333,39 +3333,6 @@  (define-public rust-argh-0.1
     (description "Derive-based argument parser optimized for code size")
     (license license:bsd-3)))
 
-(define-public rust-argon2rs-0.2
-  (package
-    (name "rust-argon2rs")
-    (version "0.2.5")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "argon2rs" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "14mkgkrjd4b4zy92pflz6yb4j1wn2chbd8jczxknxbkdm2vb0rrz"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-blake2-rfc" ,rust-blake2-rfc-0.2)
-        ("rust-scoped-threadpool" ,rust-scoped-threadpool-0.1))
-       #:cargo-development-inputs
-       (("rust-cargon" ,rust-cargon-0.0))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-cargo-toml
-           (lambda _
-             (substitute* "Cargo.toml"
-               (("\\{ path =.*,") "{"))
-             #t)))))
-    (home-page "https://github.com/bryant/argon2rs")
-    (synopsis "Rust password hashing library that runs on Argon2")
-    (description "This package provides a pure Rust password hashing library
-that runs on Argon2.")
-    (license license:expat)))
-
 (define-public rust-arr-macro-impl-0.1
   (package
     (name "rust-arr-macro-impl")