diff mbox series

[bug#58614,v2,164/192] gnu: Remove rust-win-crypto-ng-0.4.

Message ID ef22d5bc07b380cc05d598134295c38b5f085f27.1666519345.git.efraim@flashner.co.il
State New
Headers show
Series Remove unused crates | expand

Commit Message

Efraim Flashner Oct. 23, 2022, 10:04 a.m. UTC
* gnu/packages/crates-io.scm (rust-win-crypto-ng-0.4): Delete variable.
---
 gnu/packages/crates-io.scm | 36 ------------------------------------
 1 file changed, 36 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 73a37b6f82..59adde821c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69921,42 +69921,6 @@  (define-public rust-wincolor-0.1
        #:cargo-inputs
        (("rust-winapi" ,rust-winapi-0.3))))))
 
-(define-public rust-win-crypto-ng-0.4
-  (package
-    (name "rust-win-crypto-ng")
-    (version "0.4.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "win-crypto-ng" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32 "0v26ssjip8fdilj1j6csnvcny98gb90ra1qlnm2xwjlgivlr5kr4"))))
-    (build-system cargo-build-system)
-    (arguments
-      `(#:skip-build? #t
-        #:cargo-inputs
-        (("rust-cipher" ,rust-cipher-0.2)
-         ("rust-doc-comment" ,rust-doc-comment-0.3)
-         ("rust-rand-core" ,rust-rand-core-0.5)
-         ("rust-winapi" ,rust-winapi-0.3)
-         ("rust-zeroize" ,rust-zeroize-1))))
-    (home-page "https://crates.io/crates/win-crypto-ng")
-    (synopsis "Safe bindings to MS Windows Cryptography API Next
-Generation")
-    (description
-      "Cryptography API Next Generation (CNG) are cryptographic
-primitives and utilities provided by the operating system and/or
-hardware.  It is available since Windows Vista and replaces the now
-deprecated CryptoAPI.
-
-The primitives do not depend on OpenSSL or other libraries of the
-sort, they are provided by Microsoft and/or by the hardware
-manufacturer.  They are the primitives used in kernel space programs.
-Therefore, if you are using Microsoft Windows, you already accepted to
-trust these primitives.")
-    (license license:bsd-3)))
-
 (define-public rust-winpty-sys-0.4
   (package
     (name "rust-winpty-sys")