diff mbox series

[bug#70107,2/3] gnu: blueprint-compiler: Update to 0.12.0.

Message ID 55d1171e5191a507233c364dec77205c895d4cb9.1711896729.git.liliana.prikler@gmail.com
State New
Headers show
Series Update Komikku | expand

Commit Message

Liliana Marie Prikler March 31, 2024, 2:48 p.m. UTC
* gnu/packages/gnome.scm (blueprint-compiler): Update to 0.12.0.
[arguments]: Remove ‘wrap-gi’ phase, add ‘pre-check’.
[native-inputs]: Add libadwaita and xorg-server-for-tests.  Reindent.
---
 gnu/packages/gnome.scm | 20 +++++++++++---------
 1 file changed, 11 insertions(+), 9 deletions(-)

Comments

Maxim Cournoyer April 3, 2024, 3:45 a.m. UTC | #1
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/gnome.scm (blueprint-compiler): Update to 0.12.0.
> [arguments]: Remove ‘wrap-gi’ phase, add ‘pre-check’.
> [native-inputs]: Add libadwaita and xorg-server-for-tests.  Reindent.

I suppose the GI wrapping was in order for the test suite to pass only,
rather than being useful at run time?

If so, LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 42f758f8d8..8cf138b650 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3278,7 +3278,7 @@  (define-public glade3
 (define-public blueprint-compiler
   (package
     (name "blueprint-compiler")
-    (version "0.4.0")
+    (version "0.12.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3288,7 +3288,7 @@  (define-public blueprint-compiler
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0hj7f4xhwjc4x32r3lswwclbw37fw3spy806g4plkmym25hz4ydy"))))
+                "15cm2bksmygf8sifryrawxxblvvw27p4w3m42gvp3jlq50a15xm6"))))
     (build-system meson-build-system)
     (arguments
      (list
@@ -3303,13 +3303,15 @@  (define-public blueprint-compiler
       #~(modify-phases %standard-phases
           (add-after 'wrap 'wrap-python
             (assoc-ref python:%standard-phases 'wrap))
-          (add-after 'wrap-python 'wrap-gi
-            (lambda* (#:key outputs #:allow-other-keys)
-              (let ((out               (assoc-ref outputs "out"))
-                    (gi-typelib-path   (getenv "GI_TYPELIB_PATH")))
-                (wrap-program (string-append out "/bin/blueprint-compiler")
-                  `("GI_TYPELIB_PATH" ":" suffix (,gi-typelib-path)))))))))
-    (native-inputs (list gtk python-pygobject python))
+          (add-before 'check 'pre-check
+            (lambda _
+              (system "Xvfb :1 &")
+              (setenv "DISPLAY" ":1"))))))
+    (native-inputs (list gtk
+                         libadwaita
+                         python
+                         python-pygobject
+                         xorg-server-for-tests))
     (inputs (list python))
     (synopsis "Template markup language")
     (description