diff mbox series

[bug#70107,1/3] gnu: Add python-colorthief.

Message ID 044d88017b0b844348c5e3d1fff3d3cbc0371fb7.1711896729.git.liliana.prikler@gmail.com
State New
Headers show
Series Update Komikku | expand

Commit Message

Liliana Marie Prikler March 31, 2024, 2:48 p.m. UTC
* gnu/packages/python-xyz.scm (python-colorthief): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Maxim Cournoyer April 3, 2024, 3:43 a.m. UTC | #1
Hello!

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> * gnu/packages/python-xyz.scm (python-colorthief): New variable.
> ---
>  gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index cd10f304c8..ae984c493b 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -1078,6 +1078,25 @@ (define-public python-colorful
>  as functions or string constants to form colored terminal output.")
>      (license license:expat)))
>  
> +(define-public python-colorthief
> +  (package
> +    (name "python-colorthief")
> +    (version "0.2.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "colorthief" version))
> +       (sha256
> +        (base32 "08bjsmmkihyksms2vgndslln02rvw56lkxz28d39qrnxbg4v1707"))))
> +    (build-system pyproject-build-system)
> +    (propagated-inputs (list python-pillow))
> +    (home-page "https://github.com/fengsp/color-thief-py")
> +    (synopsis "Grab the color palette from an image.")

There should be no period in the synopsis ('guix lint' is a useful
reminder of that).

> +    (description
> +     "This package provides a module for grabbing the color palette from an
> +image.")

I haven't read the upstream description of the package, but if they have
something more to say, I think the description could be a little bit
more descriptive :-).
Liliana Marie Prikler April 3, 2024, 8:12 p.m. UTC | #2
Am Dienstag, dem 02.04.2024 um 23:43 -0400 schrieb Maxim Cournoyer:
> Hello!
> 
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
> 
> > * gnu/packages/python-xyz.scm (python-colorthief): New variable.
> > ---
> >  gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
> >  1 file changed, 19 insertions(+)
> > 
> > diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-
> > xyz.scm
> > index cd10f304c8..ae984c493b 100644
> > --- a/gnu/packages/python-xyz.scm
> > +++ b/gnu/packages/python-xyz.scm
> > @@ -1078,6 +1078,25 @@ (define-public python-colorful
> >  as functions or string constants to form colored terminal
> > output.")
> >      (license license:expat)))
> >  
> > +(define-public python-colorthief
> > +  (package
> > +    (name "python-colorthief")
> > +    (version "0.2.1")
> > +    (source
> > +     (origin
> > +       (method url-fetch)
> > +       (uri (pypi-uri "colorthief" version))
> > +       (sha256
> > +        (base32
> > "08bjsmmkihyksms2vgndslln02rvw56lkxz28d39qrnxbg4v1707"))))
> > +    (build-system pyproject-build-system)
> > +    (propagated-inputs (list python-pillow))
> > +    (home-page "https://github.com/fengsp/color-thief-py")
> > +    (synopsis "Grab the color palette from an image.")
> 
> There should be no period in the synopsis ('guix lint' is a useful
> reminder of that).
> 
> > +    (description
> > +     "This package provides a module for grabbing the color
> > palette from an
> > +image.")
> 
> I haven't read the upstream description of the package, but if they
> have something more to say, I think the description could be a little
> bit more descriptive :-).
Well, they don't, but I've locally expanded it to
"This package provides methods to determine the dominant color
of an image, as well as constructing a representative color palette."

WDYT?
Maxim Cournoyer April 4, 2024, 1:11 p.m. UTC | #3
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Dienstag, dem 02.04.2024 um 23:43 -0400 schrieb Maxim Cournoyer:
>> Hello!
>> 
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>> 
>> > * gnu/packages/python-xyz.scm (python-colorthief): New variable.

[...]

>> I haven't read the upstream description of the package, but if they
>> have something more to say, I think the description could be a little
>> bit more descriptive :-).
> Well, they don't, but I've locally expanded it to
> "This package provides methods to determine the dominant color
> of an image, as well as constructing a representative color palette."

This reads much better to me, thank you!  LGTM.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd10f304c8..ae984c493b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1078,6 +1078,25 @@  (define-public python-colorful
 as functions or string constants to form colored terminal output.")
     (license license:expat)))
 
+(define-public python-colorthief
+  (package
+    (name "python-colorthief")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "colorthief" version))
+       (sha256
+        (base32 "08bjsmmkihyksms2vgndslln02rvw56lkxz28d39qrnxbg4v1707"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-pillow))
+    (home-page "https://github.com/fengsp/color-thief-py")
+    (synopsis "Grab the color palette from an image.")
+    (description
+     "This package provides a module for grabbing the color palette from an
+image.")
+    (license license:bsd-3)))
+
 (define-public python-construct-classes
   (package
     (name "python-construct-classes")