diff mbox series

[bug#69424,3/5] gnu: font-google-noto-emoji: Update to 2.042.

Message ID 55c7838b2dfebd7b7205b3aa0d2c22a1b18a2061.1709038102.git.hako@ultrarare.space
State New
Headers show
Series Update Noto fonts and switch them to variable fonts (77% size reduced). | expand

Commit Message

Hilton Chain Feb. 27, 2024, 12:54 p.m. UTC
* gnu/packages/fonts.scm (font-google-noto-emoji): Update to 2.042.
[arguments]<#:phases>: Remove 'remove-unsupported.
Replace install phase instead.

Change-Id: I76cfbf3f8d34c484ed59b99969da7d93aaf41d72
---
 gnu/packages/fonts.scm | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

--
2.41.0
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 1ed648f5a2..472853afa4 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1144,7 +1144,7 @@  (define-public font-google-noto
 (define-public font-google-noto-emoji
   (package
     (name "font-google-noto-emoji")
-    (version "2.038")
+    (version "2.042")
     (source
      (origin
        (method git-fetch)
@@ -1154,7 +1154,7 @@  (define-public font-google-noto-emoji
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1rgmcc6nqq805iqr8kvxxlk5cf50q714xaxk3ld6rjrd69kb8ix9"))))
+         "17i7awyqz9jv0j2blcf0smmpas375c3pdhjv1zqzl861g8qm1lm2"))))
     (build-system font-build-system)
     (arguments
      (list
@@ -1164,11 +1164,10 @@  (define-public font-google-noto-emoji
             (lambda _
               ;; Note this ensures the correct license file is installed.
               (chdir "fonts")))
-          (add-after 'enter-font-directory 'remove-unsupported
-            (lambda* _
-              (delete-file "NotoColorEmoji_WindowsCompatible.ttf")
-              (delete-file "Noto-COLRv1-noflags.ttf")
-              (delete-file "Noto-COLRv1.ttf"))))))
+          (replace 'install
+            (lambda _
+              (let (dir ((string-append #$output "/share/fonts/truetype")))
+                (install-file "NotoColorEmoji.ttf" dir)))))))
     (home-page "https://fonts.google.com/noto/specimen/Noto+Color+Emoji")
     (synopsis "Font for rendering color emoji characters")
     (description