diff mbox series

[bug#69006,2/2] gnu: reproc: Improve package style.

Message ID 54ce21a63b314e2bf13023b2df6f7e82e225f1bc.1707506182.git.paul@apatience.com
State New
Headers show
Series [bug#69006,1/2] gnu: reproc: Enable reproc++. | expand

Commit Message

Paul A. Patience Feb. 9, 2024, 8:02 p.m. UTC
* gnu/packages/cpp.scm (reproc)[arguments]: Use G-expressions.
<#:configure-flags>: Remove unnecessary comment and enable CMake
variable with ON rather than 1.

Change-Id: Ic5e6747e7978a40d1aab66b4c3634342736c0bcf
---
 gnu/packages/cpp.scm | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 785b001629..4523ce2b04 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1055,11 +1055,9 @@  (define-public reproc
           (base32 "09xnf8hmld1fk8j33zwlz1qcxnjdx1ncbg62csic9va4m1wc2v1d"))))
    (build-system cmake-build-system)
    (arguments
-      ;; No tests.
-    `(#:tests? #f
-      ;; Build the shared library instead of a static one.
-      #:configure-flags `("-DBUILD_SHARED_LIBS=1"
-                          "-DREPROC++=ON")))
+    (list #:tests? #f     ; No tests.
+          #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON"
+                                    "-DREPROC++=ON")))
    (native-inputs
     (list pkg-config))
    (synopsis "Process IO library")