diff mbox series

[bug#63354,4/4] gnu: python-yubikey-manager: Update to 5.1.1.

Message ID 50dbfc2145aac4c09f1e44101dbd60be3f027857.1683493656.git.pierre.langlois@gmx.com
State New
Headers show
Series Fix python-yubikey-manager build and update to 5.1.1. | expand

Commit Message

Pierre Langlois May 7, 2023, 9:19 p.m. UTC
* gnu/packages/security-tokens.scm (python-yubikey-manager): Update to
5.1.1.
[build-system]: Switch to pyproject-build-system.
[arguments]: Delete.
[propagated-inputs]: Remove python-six.  Add python-keyring.
[native-inputs]: Add python-makefun, python-poetry-code and
python-pytest.
---
 gnu/packages/security-token.scm | 23 +++++++++++------------
 1 file changed, 11 insertions(+), 12 deletions(-)

--
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 79c197cd42..4e8283a9ea 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -738,33 +738,32 @@  (define-public python-fido2
 (define-public python-yubikey-manager
   (package
     (name "python-yubikey-manager")
-    (version "4.0.7")
+    (version "5.1.1")
     (source (origin
               (method url-fetch)
               (uri (string-append
                     "https://developers.yubico.com/yubikey-manager/Releases"
-                    "/yubikey-manager-" version ".tar.gz"))
+                    "/yubikey_manager-" version ".tar.gz"))
               (sha256
                (base32
-                "0kzwal7i4kyywm4f5zh8b823mh0ih2nsh5c0c4dfn4vw3j5dnwlr"))))
-    (build-system python-build-system)
-    (arguments
-     '(;; This attempts to access
-       ;; /System/Library/Frameworks/IOKit.framework/IOKit
-       ;; The recommendation is to use tox for testing.
-       #:tests? #false))
+                "1kma08rxvpzn2gf8b9vxyyb2pvrakm7hhpdmbnb54nwbdnbxp1v4"))))
+    (build-system pyproject-build-system)
     (propagated-inputs
-     (list python-six
-           python-pyscard
+     (list python-pyscard
            python-pyusb
            python-click
            python-cryptography
+           python-keyring
            python-pyopenssl
            python-fido2))
     (inputs
      (list pcsc-lite))
     (native-inputs
-     (list swig python-mock))
+     (list swig
+           python-makefun
+           python-mock
+           python-poetry-core
+           python-pytest))
     (home-page "https://developers.yubico.com/yubikey-manager/")
     (synopsis "Command line tool and library for configuring a YubiKey")
     (description