diff mbox series

[bug#65351,3/7] gnu: cgit: Do not return #t from custom phases.

Message ID 4ff202db0479e9bf07eec575518827c4a5b0ea0a.1692348727.git.arunisaac@systemreboot.net
State New
Headers show
Series [bug#65351,1/7] gnu: cgit: Make git-source a native input. | expand

Commit Message

Arun Isaac Aug. 18, 2023, 9:03 a.m. UTC
* gnu/packages/version-control.scm (cgit)[arguments]: Do not return #t from
custom phases.
---
 gnu/packages/version-control.scm | 10 +++-------
 1 file changed, 3 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 754019a5cf..73c4d8f2df 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1073,9 +1073,7 @@  (define-public cgit
                (("groff") (which "groff")))
 
              (substitute* "filters/html-converters/rst2html"
-               (("rst2html\\.py") (which "rst2html.py")))
-
-             #t))
+               (("rst2html\\.py") (which "rst2html.py")))))
          (delete 'configure) ; no configure script
          (add-after 'build 'build-man
            (lambda* (#:key make-flags #:allow-other-keys)
@@ -1091,8 +1089,7 @@  (define-public cgit
                ;; Move the platform-dependent 'cgit.cgi' into lib to get it
                ;; stripped.
                (rename-file (string-append out "/share/cgit/cgit.cgi")
-                            (string-append out "/lib/cgit/cgit.cgi"))
-               #t)))
+                            (string-append out "/lib/cgit/cgit.cgi")))))
          (add-after 'install 'wrap-python-scripts
            (lambda* (#:key outputs #:allow-other-keys)
              (for-each
@@ -1101,8 +1098,7 @@  (define-public cgit
                                              "/lib/cgit/filters/" file)
                   `("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))))
               '("syntax-highlighting.py"
-                "html-converters/md2html"))
-             #t)))))
+                "html-converters/md2html")))))))
     (native-inputs
      `(;; Building cgit requires a Git source tree.
        ("git-source"