diff mbox series

[bug#65351,1/7] gnu: cgit: Make git-source a native input.

Message ID 441ad3b27b278d465e9e3fb92f7bcaf9f6e45256.1692348727.git.arunisaac@systemreboot.net
State New
Headers show
Series [bug#65351,1/7] gnu: cgit: Make git-source a native input. | expand

Commit Message

Arun Isaac Aug. 18, 2023, 9:03 a.m. UTC
* gnu/packages/version-control.scm (cgit)[inputs]: Move git-source to ...
[native-inputs]: ... here.
---
 gnu/packages/version-control.scm | 21 ++++++++++-----------
 1 file changed, 10 insertions(+), 11 deletions(-)


base-commit: 1b2d43fe016848ea2ec16ff18cbc14340944fc4e

Comments

Liliana Marie Prikler Aug. 18, 2023, 5:03 p.m. UTC | #1
Am Freitag, dem 18.08.2023 um 10:03 +0100 schrieb Arun Isaac:
> * gnu/packages/version-control.scm (cgit)[inputs]: Move git-source to
> ...
> [native-inputs]: ... here.
> ---
I'm still questioning as to why this is necessary and/or a good idea. 
Anyone here to give me an official answer?
Arun Isaac Aug. 21, 2023, 2:22 p.m. UTC | #2
>> * gnu/packages/version-control.scm (cgit)[inputs]: Move git-source to
>> ...
>> [native-inputs]: ... here.
>> ---
> I'm still questioning as to why this is necessary and/or a good idea. 
> Anyone here to give me an official answer?

My understanding is that git-source is an input that is only needed at
compile-time. Hence, it is a native input.
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 699a091642..7475de8fc1 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -21,7 +21,7 @@ 
 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
 ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
-;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018, 2023 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
 ;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
@@ -1104,9 +1104,6 @@  (define-public cgit
                 "html-converters/md2html"))
              #t)))))
     (native-inputs
-     ;; For building manpage.
-     (list asciidoc gzip bzip2 xz))
-    (inputs
      `(;; Building cgit requires a Git source tree.
        ("git-source"
         ,(origin
@@ -1116,13 +1113,15 @@  (define-public cgit
            (uri "mirror://kernel.org/software/scm/git/git-2.25.4.tar.xz")
            (sha256
             (base32 "11am6s46wmn1yll5614smjhzlghbqq6gysgcs64igjr9y5wzpdxq"))))
-       ("openssl" ,openssl)
-       ("groff" ,groff)
-       ("python" ,python)
-       ("python-docutils" ,python-docutils)
-       ("python-markdown" ,python-markdown)
-       ("python-pygments" ,python-pygments)
-       ("zlib" ,zlib)))
+       ;; For building manpage.
+       ("asciidoc" ,asciidoc)
+       ("gzip" ,gzip)
+       ("bzip2" ,bzip2)
+       ("xz" ,xz)))
+    (inputs
+     (list openssl groff
+           python python-docutils python-markdown python-pygments
+           zlib))
     (home-page "https://git.zx2c4.com/cgit/")
     (synopsis "Web frontend for git repositories")
     (description