diff mbox series

[bug#61148,1/5] gnu: intervaltree: Update to 0.1-1.aa59377.

Message ID 4fd1568af1aa4bafb18a1efbcdfd084ca6b18711.1674997469.git.efraim@flashner.co.il
State New
Headers show
Series Update vcflib | expand

Commit Message

Efraim Flashner Jan. 29, 2023, 1:12 p.m. UTC
* gnu/packages/bioinformatics.scm (intervaltree): Update to
0.1-1.aa59377.
[arguments]: Fix cross-compiling.
---
 gnu/packages/bioinformatics.scm | 17 ++++++++++-------
 1 file changed, 10 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8c75607a65..5cea726f8e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13632,10 +13632,10 @@  (define-public gffcompare
         license:artistic2.0)))))        ;license for gclib
 
 (define-public intervaltree
-  (let ((commit "b90527f9e6d51cd36ecbb50429e4524d3a418ea5"))
+  (let ((commit "aa5937755000f1cd007402d03b6f7ce4427c5d21"))
     (package
       (name "intervaltree")
-      (version (git-version "0.0.0" "1" commit))
+      (version (git-version "0.1" "1" commit))
       (source
         (origin
           (method git-fetch)
@@ -13644,15 +13644,18 @@  (define-public intervaltree
                  (commit commit)))
           (file-name (git-file-name name version))
           (sha256
-           (base32 "0rgv6q5fl4x5d74n6p5wvdna6zmbdbqpb4jqqh6vq3670gn08xad"))))
+           (base32 "0p9aphy6sc01dg67xzqpnhvjmk21xa380bpfbkz24a23s6krhjwl"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:tests? #f                    ; No tests.
+       (list
+         #:tests? #f                    ; No tests.
          #:make-flags
-         ,#~(list (string-append "PREFIX=" #$output) "DESTDIR=\"\"")
+         #~(list (string-append "PREFIX=" #$output)
+                 (string-append "CXX=" #$(cxx-for-target))
+                 "DESTDIR=")
          #:phases
-         (modify-phases %standard-phases
-           (delete 'configure)))) ; There is no configure phase.
+         #~(modify-phases %standard-phases
+             (delete 'configure))))     ; There is no configure phase.
       (home-page "https://github.com/ekg/intervaltree")
       (synopsis "Minimal C++ interval tree implementation")
       (description "An interval tree can be used to efficiently find a set of