diff mbox series

[bug#66001,3/4] gnu: ucsim: Move documentation to "doc" output.

Message ID 4af5efd7ec061ee2ed93c77b638faf4da001a7d8.1694784333.git.simon@simonsouth.net
State New
Headers show
Series gnu: ucsim: Update to 0.8.0; other improvements. | expand

Commit Message

Simon South Sept. 15, 2023, 2:25 p.m. UTC
* gnu/packages/embedded.scm (ucsim)[arguments]<#:phases>: Expand
"patch-makefiles" phase to set correct documentation-installation path.
[outputs]: Add with "out", "doc".
---
 gnu/packages/embedded.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 80efe2363d..bee6ab6543 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1527,7 +1527,13 @@  (define-public ucsim
           (add-after 'unpack 'patch-makefiles
             (lambda _
               (substitute* (find-files "." "(\\.mk$|\\.in$)")
-                (("/bin/sh") (which "sh"))))))
+                (("/bin/sh") (which "sh")))
+
+              ;; Ensure the documentation is installed to the correct path,
+              ;; without a duplicate "ucsim" segment (necessary as we are
+              ;; building μCsim outside of SDCC).
+              (substitute* "doc/Makefile.in"
+                (("@docdir@/ucsim") "@docdir@")))))
       ;; μCsim's regression-test suite is of little use in this context since
       ;; it doesn't stop or return an error code when it encounters a problem.
       #:tests? #f))
@@ -1535,6 +1541,7 @@  (define-public ucsim
      (list ncurses))
     (native-inputs
      (list bison flex))
+    (outputs '("out" "doc"))
     (home-page "http://mazsola.iit.uni-miskolc.hu/ucsim/")
     (synopsis "Simulators for various microcontroller families")
     (description "μCsim is a collection of software simulators for