diff mbox series

[bug#67814,2/3] gnu: libplacebo: Update to 6.338.1.

Message ID 4929734bbe5aa6b4c206ce132e5e940f35a5034f.1702486251.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series gnu: mpv: Update to 0.37.0. | expand

Commit Message

Z572 Dec. 13, 2023, 4:57 p.m. UTC
* gnu/packages/video.scm (libplacebo): Update to 6.338.1.
[native-inputs]: Add python-jinja2, glad.

Change-Id: Ie9c35cfd964f110ff95ed486ee1c4f5724c82314
---
 gnu/packages/video.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 51ebc2a1b2..1f339df517 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -67,6 +67,7 @@ 
 ;;; Copyright © 2023 Dominik Delgado Steuter <dds@disroot.org>
 ;;; Copyright © 2023 Saku Laesvuori <saku@laesvuori.fi>
 ;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1533,7 +1534,7 @@  (define-public libmatroska
 (define-public libplacebo
   (package
     (name "libplacebo")
-    (version "4.208.0")
+    (version "6.338.1")
     (source
      (origin
        (method git-fetch)
@@ -1542,7 +1543,7 @@  (define-public libplacebo
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "161dp5781s74ca3gglaxlmchx7glyshf0wg43w98pl22n1jcm5qk"))))
+        (base32 "1miqk3gfwah01xkf4a6grwq29im0lfh94gp92y7js855gx3v169m"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
@@ -1551,7 +1552,11 @@  (define-public libplacebo
                          (assoc-ref %build-inputs "vulkan-headers")
                          "/share/vulkan/registry/vk.xml"))))
     (native-inputs
-     (list python python-mako pkg-config))
+     (list python python-mako
+           pkg-config
+           ;; This package use glad as library, so we add it.
+           python-jinja2
+           glad))
     (inputs
      (list lcms
            libepoxy