diff mbox series

[bug#62389,v3,4/5] gnu: Add python-txredisapi.

Message ID 4882683b4a876fede2a33912c9012b94f7f56bf4.1707681223.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62389,v3,1/5] gnu: Add python-matrix-common. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 7:55 p.m. UTC
* gnu/packages/python-xyz.scm (python-txredisapi): New variable.

Change-Id: Iab480fcfd28fd607d5d0c614d89128ee7128aa98
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8bce7ea8aa..8ee8f99b61 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27909,6 +27909,25 @@  (define-public python-txaio
 @code{asyncio} module and @code{Twisted}.")
     (license license:expat)))
 
+(define-public python-txredisapi
+  (package
+    (name "python-txredisapi")
+    (version "1.4.9")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "txredisapi" version))
+              (sha256
+               (base32
+                "0na5x3b53ni98h1cyakac36mqzgyldvfn6a7z270nkays1i70q69"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pyopenssl python-six python-twisted))
+    (home-page "http://github.com/IlyaSkriblovsky/txredisapi")
+    (synopsis "Non-blocking redis client for Python")
+    (description "Non-blocking client driver for the redis database, written
+in Python.  It uses Twisted for the asynchronous communication with
+redis.")
+    (license license:asl2.0)))
+
 (define-public python-toolshed
   (package
     (name "python-toolshed")