diff mbox series

[bug#62389,v3,2/5] gnu: python-twisted: Update to 22.10.0.

Message ID 3fdae0d0e9b6e3ba4a69d1d2278214b32674f8a7.1707681223.git.mail@migalmoreno.com
State New
Headers show
Series [bug#62389,v3,1/5] gnu: Add python-matrix-common. | expand

Commit Message

Miguel Ángel Moreno Feb. 11, 2024, 7:54 p.m. UTC
* gnu/packages/python-xyz.scm (python-twisted): Update to 22.10.0.
[arguments]: Disable tests and add phases.
[inputs]: Add python's tk output as a dependency.
[native-inputs]: Add Python dependencies.

Change-Id: I841fbe5923875f2d4bb760619b9ac3710ed06bad
---
 gnu/packages/python-xyz.scm | 31 +++++++++++++++++++------------
 1 file changed, 19 insertions(+), 12 deletions(-)

-- 
2.41.0



-- 
Best regards,
Miguel Ángel Moreno
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8aaf2d63d3..8bce7ea8aa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19874,30 +19874,37 @@  (define-public python-fastimport
 (define-public python-twisted
   (package
     (name "python-twisted")
-    (version "19.7.0")
+    (version "22.10.0")
     (source (origin
               (method url-fetch)
-              (uri (pypi-uri "Twisted" version ".tar.bz2"))
+              (uri (pypi-uri "Twisted" version ".tar.gz"))
               (sha256
                (base32
-                "17d3hnxv9qndagzz63mdpyk99xj63p9gq586vjn0rxk8cl197nym"))))
+                "0cad5n7h8nd0nyl865sn8l4ja0mkwbx9n41cnkklcpsgm50bvb1j"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f                    ; FIXME: some tests fail
-       #:phases
-       (modify-phases %standard-phases
-         ;; Remove scripts, because they depend on [conch]
-         (add-after 'unpack 'remove-entrypoint
-           (lambda _
-             (substitute* "src/twisted/python/_setup.py"
-               (("\".+ = twisted\\.conch\\.scripts\\..+\",") "")))))))
+     (list
+      #:tests? #f                       ; FIXME: some tests fail
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'adjust-for-older-attrs
+            (lambda _
+              (substitute* (find-files "." "\\.py$")
+                (("from attrs\\b")
+                 "from attr")))))))
+    (inputs (list (list python "tk")))
+    (native-inputs (list python-wheel))
     (propagated-inputs
      (list python-zope-interface
            python-pyhamcrest
            python-incremental
            python-hyperlink
            python-constantly
-           python-automat))
+           python-automat
+           python-typing-extensions
+           python-bcrypt
+           python-cryptography
+           python-pyasn1))
     (home-page "https://twistedmatrix.com/")
     (synopsis "Asynchronous networking framework written in Python")
     (description