diff mbox series

[bug#58012,core-updates,6/7] gnu: python-setools: Update to 4.4.0.

Message ID 481dc680d61463c6a7a578c5e30ee26504e47fc9.1663875245.git.code@greghogan.com
State Accepted
Headers show
Series Update python-networkx. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Sept. 22, 2022, 7:44 p.m. UTC
* gnu/packages/selinux.scm (python-setools): Update to 4.4.0.
[source, home-page]: Update url.
[inputs]: Add python-pyqt.
[native-inputs]: Add python-cython.
---
 gnu/packages/selinux.scm | 13 +++++++------
 1 file changed, 7 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index b4f074b695..d898b55129 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -42,6 +42,7 @@  (define-module (gnu packages selinux)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages swig)
   #:use-module (gnu packages xml))
 
@@ -305,16 +306,16 @@  (define-public python-sepolgen
 (define-public python-setools
   (package
     (name "python-setools")
-    (version "4.1.1")
+    (version "4.4.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/TresysTechnology/setools")
+                    (url "https://github.com/SELinuxProject/setools")
                     (commit version)))
               (file-name (string-append name "-" version "-checkout"))
               (sha256
                (base32
-                "0459xxly6zzqc5azcwk3rbbcxvj60dq08f8z6xr05y7dsbb16cg6"))))
+                "1qvd5j6zwq4fmlahg45swjplhif2z89x7s6pnp07gvcp2fbqdsh5"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ; the test target causes a rebuild
@@ -339,10 +340,10 @@  (define-public python-setools
     (propagated-inputs
      (list python-networkx))
     (inputs
-     (list libsepol libselinux))
+     (list libsepol libselinux python-pyqt))
     (native-inputs
-     (list bison flex swig))
-    (home-page "https://github.com/TresysTechnology/setools")
+     (list bison flex python-cython swig))
+    (home-page "https://github.com/SELinuxProject/setools")
     (synopsis "Tools for SELinux policy analysis")
     (description "SETools is a collection of graphical tools, command-line
 tools, and libraries designed to facilitate SELinux policy analysis.")