diff mbox series

[bug#58012,core-updates,3/7] gnu: Add python-jschema-to-python.

Message ID 0e6d1dd294b092821cfc90844d3949e86af93d7a.1663875245.git.code@greghogan.com
State Accepted
Headers show
Series Update python-networkx. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Sept. 22, 2022, 7:44 p.m. UTC
* gnu/packages/python-web.scm (python-jschema-to-python): New variable.
---
 gnu/packages/python-web.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index be780e5d3c..6a7c4be531 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -757,6 +757,25 @@  (define-public python-cfn-lint
 for resource properties and best practices.")
     (license license:expat)))
 
+(define-public python-jschema-to-python
+  (package
+    (name "python-jschema-to-python")
+    (version "1.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "jschema_to_python" version))
+              (sha256
+               (base32
+                "14cvaiwm56g0v6p7zviikaa5i9ln3yqy910jmp60hirhbpz19zvn"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-attrs python-jsonpickle python-pbr))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/microsoft/jschema-to-python")
+    (synopsis "Generate Python classes from a JSON schema.")
+    (description "This package generates source code for Python classes from a
+@url{http://jschema.org,JSchema} JSON schema.")
+    (license license:expat)))
+
 (define-public python-falcon
   (package
     (name "python-falcon")