diff mbox series

[bug#68495,2/2] gnu: bcachefs-tools: Restyle format.

Message ID 47ec0f53c75d2db052eabb006025712d4ba862e6.1705379539.git.a.r.draidi@redscript.org
State New
Headers show
Series Update bcachefs-tools to 1.4.1 and restyle | expand

Commit Message

Ahmad Draidi Jan. 16, 2024, 4:32 a.m. UTC
* gnu/packages/file-systems.scm (bcachefs-tools): Reindent all lines.

Change-Id: I6f3ae711daf2f5d66724f513fe5e8876147f5ccf
---
 gnu/packages/file-systems.scm | 186 +++++++++++++++++-----------------
 1 file changed, 93 insertions(+), 93 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index b0bf09625c..87af8ac925 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -581,98 +581,98 @@  (define-public gphotofs
     (license license:gpl2+)))
 
 (define-public bcachefs-tools
-    (package
-      (name "bcachefs-tools")
-      (version "1.4.1")
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://evilpiepirate.org/git/bcachefs-tools.git")
-               (commit (string-append "v" version))))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "0axwbckqrw1v3v50nzhpkvpyjbjwy3rq5bv23db84x3xia497apq"))))
-      (build-system gnu-build-system)
-      (arguments
-       (list #:make-flags
-             #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
-                     (string-append "PREFIX=" #$output)
-                     "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
-                     "PKGCONFIG_UDEVRULESDIR=$(PREFIX)/lib/udev/rules.d"
-                     (string-append "CC=" #$(cc-for-target))
-                     (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
-                     ;; ‘This will be less of an option in the future, as more
-                     ;; code gets rewritten in Rust.’
-                     "NO_RUST=better")
-             #:phases
-             #~(modify-phases %standard-phases
-                 (delete 'configure)    ; no configure script
-                 (replace 'check
-                   ;; The test suite is moribund upstream (‘never been useful’),
-                   ;; but let's keep running it as a sanity check until then.
-                   (lambda* (#:key tests? make-flags #:allow-other-keys)
-                     (when tests?
-                       ;; We must manually build the test_helper first.
-                       (apply invoke "make" "tests" make-flags)
-                       (invoke (string-append
-                                #$(this-package-native-input "python-pytest")
-                                "/bin/pytest") "-k"
-                                ;; These fail (‘invalid argument’) on kernels
-                                ;; with a previous bcachefs version.
-                                (string-append "not test_format and "
-                                               "not test_fsck and "
-                                               "not test_list and "
-                                               "not test_list_inodes and "
-                                               "not test_list_dirent")))))
-                 (add-after 'install 'promote-mount.bcachefs.sh
-                   ;; The (optional) ‘mount.bcachefs’ requires rust:cargo.
-                   ;; This shell alternative does the job well enough for now.
-                   (lambda* (#:key inputs #:allow-other-keys)
-                     (define (whence file)
-                       (dirname (search-input-file inputs file)))
-                     (let ((mount (string-append #$output
-                                                 "/sbin/mount.bcachefs")))
-                       (delete-file mount) ; symlink to ‘bcachefs’
-                       (copy-file "mount.bcachefs.sh" mount)
-                       ;; WRAP-SCRIPT causes bogus ‘Insufficient arguments’ errors.
-                       (wrap-program mount
-                         `("PATH" ":" prefix
-                           ,(list (getcwd)
-                                  (whence "bin/tail")
-                                  (whence "bin/awk")
-                                  (whence "bin/mount"))))))))))
-      (native-inputs
-       (cons* pkg-config
-              ;; For generating documentation with rst2man.
-              python
-              python-docutils
-              ;; For tests.
-              python-pytest
-              (if (member (%current-system) (package-supported-systems valgrind))
-                  (list valgrind)
-                  '())))
-      (inputs
-       (list eudev
-             keyutils
-             libaio
-             libscrypt
-             libsodium
-             liburcu
-             `(,util-linux "lib")
-             lz4
-             zlib
-             `(,zstd "lib")
-
-             ;; Only for mount.bcachefs.sh.
-             bash-minimal
-             coreutils-minimal
-             gawk
-             util-linux))
-      (home-page "https://bcachefs.org/")
-      (synopsis "Tools to create and manage bcachefs file systems")
-      (description
-       "The bcachefs-tools are command-line utilities for creating, checking,
+  (package
+    (name "bcachefs-tools")
+    (version "1.4.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://evilpiepirate.org/git/bcachefs-tools.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0axwbckqrw1v3v50nzhpkvpyjbjwy3rq5bv23db84x3xia497apq"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags
+           #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
+                   (string-append "PREFIX=" #$output)
+                   "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
+                   "PKGCONFIG_UDEVRULESDIR=$(PREFIX)/lib/udev/rules.d"
+                   (string-append "CC=" #$(cc-for-target))
+                   (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+                   ;; ‘This will be less of an option in the future, as more
+                   ;; code gets rewritten in Rust.’
+                   "NO_RUST=better")
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)    ; no configure script
+               (replace 'check
+                 ;; The test suite is moribund upstream (‘never been useful’),
+                 ;; but let's keep running it as a sanity check until then.
+                 (lambda* (#:key tests? make-flags #:allow-other-keys)
+                   (when tests?
+                     ;; We must manually build the test_helper first.
+                     (apply invoke "make" "tests" make-flags)
+                     (invoke (string-append
+                              #$(this-package-native-input "python-pytest")
+                              "/bin/pytest") "-k"
+                              ;; These fail (‘invalid argument’) on kernels
+                              ;; with a previous bcachefs version.
+                              (string-append "not test_format and "
+                                             "not test_fsck and "
+                                             "not test_list and "
+                                             "not test_list_inodes and "
+                                             "not test_list_dirent")))))
+               (add-after 'install 'promote-mount.bcachefs.sh
+                 ;; The (optional) ‘mount.bcachefs’ requires rust:cargo.
+                 ;; This shell alternative does the job well enough for now.
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (define (whence file)
+                     (dirname (search-input-file inputs file)))
+                   (let ((mount (string-append #$output
+                                               "/sbin/mount.bcachefs")))
+                     (delete-file mount) ; symlink to ‘bcachefs’
+                     (copy-file "mount.bcachefs.sh" mount)
+                     ;; WRAP-SCRIPT causes bogus ‘Insufficient arguments’ errors.
+                     (wrap-program mount
+                       `("PATH" ":" prefix
+                         ,(list (getcwd)
+                                (whence "bin/tail")
+                                (whence "bin/awk")
+                                (whence "bin/mount"))))))))))
+    (native-inputs
+     (cons* pkg-config
+            ;; For generating documentation with rst2man.
+            python
+            python-docutils
+            ;; For tests.
+            python-pytest
+            (if (member (%current-system) (package-supported-systems valgrind))
+                (list valgrind)
+                '())))
+    (inputs
+     (list eudev
+           keyutils
+           libaio
+           libscrypt
+           libsodium
+           liburcu
+           `(,util-linux "lib")
+           lz4
+           zlib
+           `(,zstd "lib")
+
+           ;; Only for mount.bcachefs.sh.
+           bash-minimal
+           coreutils-minimal
+           gawk
+           util-linux))
+    (home-page "https://bcachefs.org/")
+    (synopsis "Tools to create and manage bcachefs file systems")
+    (description
+     "The bcachefs-tools are command-line utilities for creating, checking,
 and otherwise managing bcachefs file systems.
 
 Bcachefs is a @acronym{CoW, copy-on-write} file system supporting native
@@ -682,7 +682,7 @@  (define-public bcachefs-tools
 In addition, bcachefs provides all the functionality of bcache, a block-layer
 caching system, and lets you assign different roles to each device based on its
 performance and other characteristics.")
-      (license license:gpl2+)))
+    (license license:gpl2+)))
 
 (define-public bcachefs-tools/static
   (package