diff mbox series

[bug#68495,1/2] gnu: bcachefs-tools: Update to 1.4.1.

Message ID 0f7d0c5dd9fc6021d775cb31c8e5c54d569e4576.1705379539.git.a.r.draidi@redscript.org
State New
Headers show
Series Update bcachefs-tools to 1.4.1 and restyle | expand

Commit Message

Ahmad Draidi Jan. 16, 2024, 4:32 a.m. UTC
* gnu/packages/file-systems.scm (bcachefs-tools): Update to 1.4.1.
[source]: Use version instead of commit.
[arguments]:<#:make-flags>: Add "PKGCONFIG_UDEVRULESDIR" to put udev rules
under "PREFIX" folder.
[inputs]: Add bash-minimal to fix lint.

Change-Id: I6818bc41260586664d408234323bdc9461e4b8e1
---
 gnu/packages/file-systems.scm | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)


base-commit: 162d6a2fdd6af13272967c77347a54934ecb45e6
diff mbox series

Patch

diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 8cac1eae9c..b0bf09625c 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -581,26 +581,25 @@  (define-public gphotofs
     (license license:gpl2+)))
 
 (define-public bcachefs-tools
-  (let ((commit "1e358401ecdf1963e5799de19ab69111e82e5ebc")
-        (revision "0"))
     (package
       (name "bcachefs-tools")
-      (version (git-version "1.2" revision commit))
+      (version "1.4.1")
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://evilpiepirate.org/git/bcachefs-tools.git")
-               (commit commit)))
+               (commit (string-append "v" version))))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0bflgqb3q9jikyyrv6hywv6m1fapzzn874hlhf86pn6abxrlf5fa"))))
+          (base32 "0axwbckqrw1v3v50nzhpkvpyjbjwy3rq5bv23db84x3xia497apq"))))
       (build-system gnu-build-system)
       (arguments
        (list #:make-flags
              #~(list (string-append "VERSION=" #$version) ; ‘v…-nogit’ otherwise
                      (string-append "PREFIX=" #$output)
                      "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
+                     "PKGCONFIG_UDEVRULESDIR=$(PREFIX)/lib/udev/rules.d"
                      (string-append "CC=" #$(cc-for-target))
                      (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
                      ;; ‘This will be less of an option in the future, as more
@@ -666,6 +665,7 @@  (define-public bcachefs-tools
              `(,zstd "lib")
 
              ;; Only for mount.bcachefs.sh.
+             bash-minimal
              coreutils-minimal
              gawk
              util-linux))
@@ -682,7 +682,7 @@  (define-public bcachefs-tools
 In addition, bcachefs provides all the functionality of bcache, a block-layer
 caching system, and lets you assign different roles to each device based on its
 performance and other characteristics.")
-      (license license:gpl2+))))
+      (license license:gpl2+)))
 
 (define-public bcachefs-tools/static
   (package