diff mbox series

[bug#60429,4/5] gnu: yosys: Propagate external dependencies.

Message ID 477fccd0f411dc2e6cccd91106116e6d71fc58f9.1672412713.git.simon@simonsouth.net
State New
Headers show
Series gnu: yosys: Update to 0.24. | expand

Commit Message

Simon South Dec. 30, 2022, 4 p.m. UTC
* gnu/packages/fpga.scm (yosys)[inputs]: Move graphviz, psmisc, xdot from
here...
[propagated-inputs]: ...to here, to ensure the availability at runtime of
executables invoked by yosys' "show" command.
[arguments]: Remove now-obsolete "fix-paths" phase.
---
 gnu/packages/fpga.scm | 20 +++++---------------
 1 file changed, 5 insertions(+), 15 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 8effebd921..785d385621 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -157,16 +157,6 @@  (define-public yosys
                            (string-append "PREFIX=" #$output))
       #:phases
       #~(modify-phases %standard-phases
-          (add-before 'configure 'fix-paths
-            (lambda* (#:key inputs #:allow-other-keys)
-              (substitute* "./passes/cmds/show.cc"
-                (("exec xdot")
-                 (string-append "exec " (search-input-file inputs
-                                                           "/bin/xdot")))
-                (("dot -")
-                 (string-append (search-input-file inputs "/bin/dot") " -"))
-                (("fuser")
-                 (search-input-file inputs "/bin/fuser")))))
           (replace 'configure
             (lambda* (#:key make-flags #:allow-other-keys)
               (apply invoke "make" "config-gcc" make-flags)))
@@ -211,14 +201,14 @@  (define-public yosys
            python
            tcl)) ; tclsh for the tests
     (inputs
-     (list graphviz
-           libffi
-           psmisc
+     (list libffi
            readline
-           tcl
-           xdot))
+           tcl))
     (propagated-inputs
      (list abc
+           graphviz ; for dot
+           psmisc ; for fuser
+           xdot
            z3)) ; should be in path for yosys-smtbmc
     (home-page "https://yosyshq.net/yosys/")
     (synopsis "FPGA Verilog RTL synthesizer")