diff mbox series

[bug#50054,v2,1/3] gnu: Add bx

Message ID 477d78831968e9647256065d680429f128529ef2.1713851192.git.atai@atai.org
State New
Headers show
Series *** Add bgfx and dependencies *** | expand

Commit Message

Andy Tai April 23, 2024, 5:51 a.m. UTC
* gnu/packages/graphics.scm (bx): New variable

Change-Id: I7a0b4ccfb2e7a1edad80da0ba55fa5cd0fca0032
---
 gnu/packages/graphics.scm | 60 ++++++++++++++++++++++++++++++++++++++-
 1 file changed, 59 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index ca2d74224f..b64774af58 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -24,7 +24,7 @@ 
 ;;; Copyright © 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
-;;; Copyright © 2021 Andy Tai <atai@atai.org>
+;;; Copyright © 2021, 2024 Andy Tai <atai@atai.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
@@ -2893,6 +2893,64 @@  (define-public f3d
 options.")
     (license license:bsd-3)))
 
+(define-public bx
+  (let ((commit "d3434707384f6d62229a4476b10b6dc22fee7c9a")
+        (revision "1"))
+    (package
+      (name "bx")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/bkaradzic/bx")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "11jii8dfb0nzxamkffa6ij3p6r4w7csfbxw7wpxsmqhirv5i8rns"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+        #:phases #~(modify-phases %standard-phases
+                     (delete 'configure)
+
+                     (replace 'build
+                       (lambda _
+                         (invoke "make"
+                                  "-j" (number->string (parallel-job-count))
+                                 "linux-release64"
+                                 (string-append "GENIE="
+                                                #$(this-package-native-input
+                                                   "genie") "/bin/genie") "-j"
+                                 (number->string (parallel-job-count)))))
+
+                     (replace 'check
+                       (lambda _
+                         (invoke "make" "test")))
+                     (replace 'install
+                       (lambda _
+                         (install-file
+                          ".build/linux64_gcc/obj/x64/Release/bin2c/tools/bin2c"
+                          (string-append #$output "/bin"))
+                         (install-file
+                          ".build/linux64_gcc/obj/x64/Release/lemon/tools/lemon"
+                          (string-append #$output "/bin"))
+                         (for-each (lambda (f)
+                                     (install-file f
+                                                   (string-append #$output
+                                                                  "/lib")))
+                                   (find-files ".build/linux64_gcc" "\\.a$"))
+                         (copy-recursively "include/bx"
+                                           (string-append #$output
+                                                          "/include/bx")))))))
+      (native-inputs (list genie))
+      (home-page "https://github.com/bkaradzic/bx")
+      (synopsis "Base library used across multiple projects ")
+      (description
+       "Bx is an base library that implements low level functions of the
+Bgfx graphics library.")
+      (license license:bsd-2))))
+
 (define-public gpaint
   (package
     (name "gpaint")