diff mbox series

[bug#61484] gnu: kicad: Update to 7.0.0.

Message ID 46342994457a4f11100b809985bb73eef0545b7f.1676311719.git.peter@polidoro.io
State New
Headers show
Series [bug#61484] gnu: kicad: Update to 7.0.0. | expand

Commit Message

Peter Polidoro Feb. 13, 2023, 6:08 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/engineering.scm (kicad): Update to 7.0.0.
---
 gnu/packages/engineering.scm | 18 ++++++++++--------
 1 file changed, 10 insertions(+), 8 deletions(-)

Comments

Guillaume Le Vaillant Feb. 18, 2023, 10:33 a.m. UTC | #1
Patch pushed as 224bcf4f1d9995440cbd899496b9d9be02c1d49c.
Thanks.
Peter Polidoro Feb. 22, 2023, 7:12 p.m. UTC | #2
Hi, I just noticed a bug in my patch. How should I submit a fixed 
patch? Should I send to this debbug number or to a new one? Should 
I change the name from kicad-7.0.0 to indicate a different package 
definition? Or should the name still be kicad-7.0.0 since kicad is 
still at version 7.0.0? Thanks.


Guillaume Le Vaillant <glv@posteo.net> writes:

> [[PGP Signed Part:Undecided]]
> [1. text/plain]
> Patch pushed as 224bcf4f1d9995440cbd899496b9d9be02c1d49c.
> Thanks.
>
> [[End of PGP Signed Part]]
Guillaume Le Vaillant Feb. 22, 2023, 7:33 p.m. UTC | #3
Peter Polidoro <peter@polidoro.io> skribis:

> Hi, I just noticed a bug in my patch. How should I submit a fixed patch? Should
> I send to this debbug number or to a new one? Should I change the name from
> kicad-7.0.0 to indicate a different package definition? Or should the name
> still be kicad-7.0.0 since kicad is still at version 7.0.0? Thanks.

Hi.
If it's a bug in the package definition, there's no need to change the
version number. You can just send a patch which will be have a new
issue number. Something like "gnu: kicad: Fix xyz.".
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 9db6e26a02..00144a1464 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -87,6 +87,7 @@  (define-module (gnu packages engineering)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages dejagnu)
   #:use-module (gnu packages digest)
@@ -946,7 +947,7 @@  (define-public inspekt3d
 (define-public kicad
   (package
     (name "kicad")
-    (version "6.0.11")
+    (version "7.0.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -954,7 +955,7 @@  (define-public kicad
                     (commit version)))
               (sha256
                (base32
-                "1bhzmgs921wv1pc0mpyigmpp630086kmpifc3a91cbkv4xf0akkq"))
+                "1zgpj1rvf97qv36hg4dja46pbzyixlh2g04wlh7cizcrs16b9mzw"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
@@ -1015,7 +1016,8 @@  (define-public kicad
                          gettext-minimal
                          pkg-config
                          swig
-                         zlib))
+                         zlib
+                         unixodbc))
     (inputs (list bash-minimal
                   cairo
                   curl
@@ -1053,7 +1055,7 @@  (define-public kicad-doc
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0f191ifzgl2k196ph7ljip97s17gq8bsfkn1s3aza1qaafhg7acd"))))
+                "0xsj3fl6gkvyr97gx3nvy4ylcr6sc4byj4hbgcdwl2zx3wm02ifz"))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags (list "-DBUILD_FORMATS=html")
@@ -1087,7 +1089,7 @@  (define-public kicad-symbols
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1fwnr8x345jbifk71rhyd4b88c4ijp2rcw3pmivnwfb444hbr1lp"))))
+                "1r87xr1453dpfglkg1m4p5d7kcv9gxls1anwk3vp2yppnwz24ydm"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f))                    ; no tests exist
@@ -1116,7 +1118,7 @@  (define-public kicad-footprints
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1rs05n1wjb2w3x7xqkkijbdxyw3fj0fph8znvnsxp9bgwaaipd4h"))))
+                "1akhifnjm8jvqsvscn2rr1wpzrls73bpdc6sk40355r1in2djmry"))))
     (synopsis "Official KiCad footprint libraries")
     (description "This package contains the official KiCad footprint libraries.")))
 
@@ -1133,7 +1135,7 @@  (define-public kicad-packages3d
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0nmvfchp25i4bkx6yf7fz1rwy7w6whj2w7mlp02ag3w5v4f137vz"))))
+                "1qw5xm0wbhv6gqvd8mn0jp4abjbizrkx79r6y8f6911mkzi47r6n"))))
     (synopsis "Official KiCad 3D model libraries")
     (description "This package contains the official KiCad 3D model libraries.")))
 
@@ -1150,7 +1152,7 @@  (define-public kicad-templates
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "08zxh83fbygh1x2jhca8nrp3f9kihf7kmg65qmyp95wvps4p5h8v"))))
+                "02i279269mhq7wjhb1yqk90820ncssxl9n7b20qr2r4fmm7jpvxv"))))
     (synopsis "Official KiCad project and worksheet templates")
     (description "This package contains the official KiCad project and
 worksheet templates.")))