diff mbox series

[bug#39786] Add dragonfly-reverb.

Message ID 458932661ece13a229a0ca6e29d6decab90f044e.camel@zrythm.org
State Accepted
Headers show
Series [bug#39786] Add dragonfly-reverb. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou March 21, 2020, 7:09 p.m. UTC
Hi,

Thanks for the feedback.

Attaching the updated patch. I also removed some unneeded dependencies.

Thanks,
Alex

2020-03-21 (土) の 17:46 +0100 に Nicolas Goaziou さんは書きました:
> Hello,
> 
> Alexandros Theodotou <alex@zrythm.org> writes:
> 
> > This patch adds dragonfly reverb, a popular reverb plugin.
> 
> Thank you!
> 
> > +           (lambda* (#:key inputs outputs #:allow-other-keys)
> > +             (let* ((out   (assoc-ref outputs "out"))
> > +                    (bin   (string-append out "/bin"))
> > +                    (vst   (string-append out "/lib/vst"))
> > +                    (lv2   (string-append out "/lib/lv2")))
> > +               (mkdir-p bin)
> > +               (mkdir-p vst)
> > +               (mkdir-p lv2)
> > +
> > +               ;; Install VST
> > +               (for-each
> > +                 (lambda (file)
> > +                   (install-file file vst))
> > +                 (find-files "bin" "\\-vst.so$"))
> 
> Since you use `install-file' you don't need to `mkdir-p' beforehand,
> i.e., you can drop (mkdir-p vst) above.
> 
> > +               ;; Install standalone
> > +               (install-file "bin/DragonflyRoomReverb" bin)
> > +               (install-file "bin/DragonflyHallReverb" bin)
> 
> Ditto, you can drop (mkdir-p bin).
> 
> > +               #t))))))
> > +    (inputs
> > +     `(("jack" ,jack-1)
> > +       ("libx11" ,libx11)
> > +       ("mesa" ,mesa)))
> > +    (native-inputs
> > +     `(("lv2" ,lv2)
> > +       ("pkg-config" ,pkg-config)))
> > +    (synopsis "Concert hall reverb and room reverb effects")
> > +    (description
> > +     "Dragonfly Reverb is a bundle of two free audio effects: a
> > concert
> > +hall reverb and a room reverb. Both are available as VST and LV2
> > plugins,
> 
> You need to add two spaces after full stops.
> 
> Could you send an updated patch?
> 
> Regards,
>

Comments

Nicolas Goaziou March 21, 2020, 8:55 p.m. UTC | #1
Hello,

Alexandros Theodotou <alex@zrythm.org> writes:

> Attaching the updated patch. I also removed some unneeded
> dependencies.

Thank you! I applied your patch, with the following changes :

> +(define-public dragonfly-reverb

I fixed the indentation, which was a bit off,

> +           (lambda* (#:key inputs outputs #:allow-other-keys)

I removed `inputs' as it was not needed.

> +    (synopsis "Concert hall reverb and room reverb effects")
> +    (description
> +     "Dragonfly Reverb is a bundle of two free audio effects: a concert
> +hall reverb and a room reverb.  Both are available as LV2 plugins as well
> +as JACK standalone applications.")
> +    (home-page "https://michaelwillis.github.io/dragonfly-reverb/")

I moved `home-page' above `synopsis'.

Regards,
diff mbox series

Patch

From 194140d3bb34df369c585968c5ee2c93a4b41f15 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 15:17:10 +0000
Subject: [PATCH] gnu: Add dragonfly-reverb

* gnu/packages/music.scm (dragonfly-reverb): New variable.
---
 gnu/packages/music.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 16e69840df..1bdd905f77 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5189,3 +5189,55 @@  featureful and easy to use.  It offers unlimited automation options, LV2
 plugin support, JACK support and chord assistance.")
    (home-page "https://www.zrythm.org")
    (license license:agpl3+)))
+
+(define-public dragonfly-reverb
+  (package
+    (name "dragonfly-reverb")
+    (version "2.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri
+          (git-reference
+            (url "https://github.com/michaelwillis/dragonfly-reverb.git")
+            (commit version)
+            ;; bundles a specific commit of the DISTRHO plugin framework
+            (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32 "1qrbv4kk5v6ynx424h1i54qj0w8v6vpw81b759jawxvzzprpgq72"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:make-flags (list "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure) ; no configure target
+         (replace 'install ; no install target
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out   (assoc-ref outputs "out"))
+                    (bin   (string-append out "/bin"))
+                    (lv2   (string-append out "/lib/lv2")))
+               ;; Install LV2
+               (for-each
+                 (lambda (file)
+                   (copy-recursively file (string-append lv2 "/"
+                                                         (basename file))))
+                 (find-files "bin" "\\.lv2$" #:directories? #t))
+               ;; Install standalone
+               (install-file "bin/DragonflyRoomReverb" bin)
+               (install-file "bin/DragonflyHallReverb" bin)
+               #t))))))
+    (inputs
+     `(("jack" ,jack-1)
+       ("libx11" ,libx11)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (synopsis "Concert hall reverb and room reverb effects")
+    (description
+     "Dragonfly Reverb is a bundle of two free audio effects: a concert
+hall reverb and a room reverb.  Both are available as LV2 plugins as well
+as JACK standalone applications.")
+    (home-page "https://michaelwillis.github.io/dragonfly-reverb/")
+    (license license:gpl3+)))
-- 
2.25.1