diff mbox series

[bug#68153] gnu: Add python-cocotb.

Message ID 3fee261b22e793873c0624d5a4f79a1c7b85118f.1703961850.git.csantosb@inventati.org
State New
Headers show
Series [bug#68153] gnu: Add python-cocotb. | expand

Commit Message

Cayetano Santos Dec. 30, 2023, 6:44 p.m. UTC
* gnu/packages/fpga.scm (python-cocotb): New variable.

Signed-off-by: Cayetano Santos <csantosb@inventati.org>
---
 gnu/packages/fpga.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 7722da6fa5422c4fec69d6c8b9536c7d6fc3d326

Comments

Troy Figiel Dec. 31, 2023, 11:27 a.m. UTC | #1
I would love to see cocotb included in Guix. Your patch does not build
for me though, because find-libpython is missing. I took the liberty to
add it. After replacing `python-find_libpython' by
`python-find-libpython' and including my patch, your patch does
successfully build for me.

That being said, it seems cocotb actually has a very extensive set of
tests. If possible, it would be nice if these can be included as well.

Best wishes,

Troy
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 13ac1a0b57..74eff01a7a 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -422,6 +422,33 @@  (define-public python-myhdl
 a hardware description and verification language.")
     (license license:lgpl2.1+)))
 
+(define-public python-cocotb
+  (package
+    (name "python-cocotb")
+    (version "1.8.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cocotb/cocotb")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "07h8c3cjn4hhywvakcyk3chia102iszn6kjm53vl5f16rwy9xd07"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-find_libpython))
+    (arguments
+     `(#:tests? #f			; no test suite
+       ))
+    (home-page "https://github.com/cocotb/cocotb")
+    (synopsis
+     "Library for writing HDL testbenches in Python")
+    (description
+     "Coroutine based cosimulation testbench environment for
+verifying VHDL and Verilog RTL using Python.")
+    (license license:bsd-3)))
+
 (define-public nvc
   (package
     (name "nvc")