diff mbox series

[bug#60029,v3,1/3] gnu: vim: Add vim packages to 'package-path' instead of 'runtime-path'.

Message ID 3f91d5d543a57335eb10f146a1dd55fc2dab003c.1697446927.git.efraim@flashner.co.il
State New
Headers show
Series Add vim-build-system. | expand

Commit Message

Efraim Flashner Oct. 16, 2023, 9:15 a.m. UTC
From: Jonathan Scoresby <me@jonscoresby.com>

    This is neccesary because vim's built-in plugin manager looks for directories
    under 'package-path' instead of 'runtime-path.' Once we have told vim the
    package-path, it adds all the packages to the runtime-path automatically for us.

* gnu/packages/aux-files/guix.vim: Add paths to packagepath instead of
runtimepath.  Remove code to adjust runtimepath after adding paths.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
---
 gnu/packages/aux-files/guix.vim | 11 +++--------
 1 file changed, 3 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/aux-files/guix.vim b/gnu/packages/aux-files/guix.vim
index 9397c53701..24a6b941a8 100644
--- a/gnu/packages/aux-files/guix.vim
+++ b/gnu/packages/aux-files/guix.vim
@@ -1,13 +1,8 @@ 
-" This appends all of the vim plugins to the end of Vim's runtimepath.
+" This appends all applicable vim paths to the end of packagepath.  Once we
+" have told vim the packagepath vim will add it to the runtimepath for us.
 for directory in ["/run/current-system/profile", $HOME . "/.guix-profile", $HOME ."/.guix-home/profile", $GUIX_PROFILE, $GUIX_ENVIRONMENT]
     let vimplugins = directory . "/share/vim/vimfiles"
     if isdirectory(vimplugins)
-        let &rtp = join([&rtp,vimplugins], ',')
+        let &pp = join([&pp,vimplugins], ',')
     endif
 endfor
-" Unconditionally add */after directories last, as intended by upstream
-" TODO: Remove duplicate */after directories
-for directory in [$VIM . "/vimfiles", $HOME ."/.vim"]
-    let vimplugins = directory . "/after"
-    let &rtp = join([&rtp,vimplugins], ',')
-endfor