mbox series

[bug#60029,v3,0/3] Add vim-build-system.

Message ID cover.1697446927.git.efraim@flashner.co.il
Headers show
Series Add vim-build-system. | expand

Message

Efraim Flashner Oct. 16, 2023, 9:15 a.m. UTC
I dropped the first commit, adding the option of other outputs to the
copy-build-system, in the interest of getting this merged sooner.

On the first patch I fix some typos and added to the comment at the top
of the file.

On the second patch I added the entries to Makefile.am and added the
missing documentation. I added the plugin-name field (I want to run
:packadd fugitive, not :packadd vim-fugitive-3.7), moved the neovim
output into the main output, added to the exclude-regexp, and some
general code cleanup.

On the third patch I adjusted the plugin paths of some more files in
packages which came with vim plugins. I reworked vim-vlime to have the
installed packpath resemble the upstream repository, which is supposed
to work as-is.

I noticed that I need to fix vim-asyncrun, it still has the install-plan
from before. I'm unsure about setting packages like vim-rainbow to use
'opt' for mode since that seems to be upstream's default, but would be
surprising. I tried my best to come up with expected plugin-names for
all the packages.

Jonathan Scoresby (3):
  gnu: vim: Add vim packages to 'package-path' instead of
    'runtime-path'.
  build-system: Add vim-build-system.
  gnu: Have vim packages use vim-build-system.

 Makefile.am                     |   4 +-
 doc/guix.texi                   |  33 ++++
 gnu/packages/aux-files/guix.vim |  11 +-
 gnu/packages/code.scm           |   5 +-
 gnu/packages/lisp.scm           |   5 +-
 gnu/packages/mail.scm           |   3 +-
 gnu/packages/rust-apps.scm      |   3 +-
 gnu/packages/vim.scm            | 306 ++++++++++++--------------------
 gnu/packages/wm.scm             |   3 +-
 guix/build-system/vim.scm       | 157 ++++++++++++++++
 guix/build/vim-build-system.scm | 117 ++++++++++++
 11 files changed, 437 insertions(+), 210 deletions(-)
 create mode 100644 guix/build-system/vim.scm
 create mode 100644 guix/build/vim-build-system.scm


base-commit: a0d2ecde943bd1854ddbb7c0cad35a1fc64dc5ab

Comments

Efraim Flashner Nov. 8, 2023, 10:16 a.m. UTC | #1
I did another round of review on the patches (which did find some
things) and I've now pushed these patches!

Now I have to figure out how to use packadd so I can drop
editorconfig-vim since it comes with vim.