diff mbox series

[bug#62166,2/2] gnu: Add bibata-cursor-theme.

Message ID 3f5ddd04f16495750d23a474bf30c9b428b80243.1678732846.git.contact@conses.eu
State New
Headers show
Series [bug#62166,1/2] gnu: Add python-clickgen. | expand

Commit Message

Miguel Ángel Moreno March 13, 2023, 6:43 p.m. UTC
* gnu/packages/gnome-xyz.scm (bibata-cursor-theme): New variable.
---
 gnu/packages/gnome-xyz.scm | 50 +++++++++++++++++++++++++++++++++++++-
 1 file changed, 49 insertions(+), 1 deletion(-)

Comments

Andrew Tropin March 22, 2023, 9:11 a.m. UTC | #1
On 2023-03-13 19:43, conses wrote:

> * gnu/packages/gnome-xyz.scm (bibata-cursor-theme): New variable.
> ---
>  gnu/packages/gnome-xyz.scm | 50 +++++++++++++++++++++++++++++++++++++-
>  1 file changed, 49 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> index 19838c3dd5..a7414d09ee 100644
> --- a/gnu/packages/gnome-xyz.scm
> +++ b/gnu/packages/gnome-xyz.scm
> @@ -320,6 +320,54 @@ (define-public flat-remix-gnome-theme
>  highlights, and gradients for some depth.")
>      (license license:gpl3+)))
>  
> +(define-public bibata-cursor-theme
> +  (package
> +    (name "bibata-cursor-theme")
> +    (version "2.0.3")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/ful1e5/Bibata_Cursor")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1bhspswgxizc4sr2bihfjic8wm4khd6waw9qgw0yssfy0fm3nafc"))))
> +    (build-system trivial-build-system)
> +    (native-inputs (list python-attrs python-clickgen))
> +    (arguments
> +     (list
> +      #:modules '((guix build utils))
> +      #:builder
> +      #~(begin
> +          (use-modules (guix build utils))
> +          (let ((themes-dir (string-append #$output "/share/icons")))
> +            (mkdir-p themes-dir)
> +            (let loop
> +                ((themes '(("Bibata-Modern-Amber" . "Yellowish and rounded")
> +                           ("Bibata-Modern-Classic" . "Black and rounded")
> +                           ("Bibata-Modern-Ice" . "White and rounded")
> +                           ("Bibata-Original-Amber" . "Yellowish and sharp")
> +                           ("Bibata-Original-Classic" . "Black and sharp")
> +                           ("Bibata-Original-Ice" . "White and sharp"))))
> +              (define theme
> +                (car themes))
> +              (invoke #$(file-append python-clickgen "/bin/ctgen")

Changed it to
(search-input-file %build-inputs "/bin/ctgen")

> +                      (string-append #$source "/build.toml")
> +                      "-p" "x11"
> +                      "-d" (string-append #$source "/bitmaps/" (car theme))
> +                      "-n" (car theme)
> +                      "-c" (string-append (cdr theme) " edge Bibata cursors")
> +                      "-o" themes-dir)
> +              (unless (null? (cdr themes))
> +                (loop (cdr themes))))))))
> +    (home-page "https://github.com/ful1e5/Bibata_Cursor")
> +    (synopsis "Open-source, compact, and material-designed cursor set")
> +    (description
> +     "Bibata is an open-source, compact, and material designed
> +cursor set.  This project aims at improving the cursor experience.")
> +    (license license:gpl3)))
> +
>  (define-public gnome-plots
>    (package
>      (name "gnome-plots")
> @@ -1690,7 +1738,7 @@ (define-public yaru-theme
>   sound themes.
>  @end itemize")
>      (license (list license:lgpl2.1 license:lgpl3 license:cc-by-sa4.0))))
> -  
> +
>  (define-public nordic-theme
>    (let ((commit "07d764c5ebd5706e73d2e573f1a983e37b318915")
>  	(revision "0"))
> -- 
> 2.39.1

Thank you for the patch! Applied, pushed as ac64367262.
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 19838c3dd5..a7414d09ee 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -320,6 +320,54 @@  (define-public flat-remix-gnome-theme
 highlights, and gradients for some depth.")
     (license license:gpl3+)))
 
+(define-public bibata-cursor-theme
+  (package
+    (name "bibata-cursor-theme")
+    (version "2.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ful1e5/Bibata_Cursor")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bhspswgxizc4sr2bihfjic8wm4khd6waw9qgw0yssfy0fm3nafc"))))
+    (build-system trivial-build-system)
+    (native-inputs (list python-attrs python-clickgen))
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder
+      #~(begin
+          (use-modules (guix build utils))
+          (let ((themes-dir (string-append #$output "/share/icons")))
+            (mkdir-p themes-dir)
+            (let loop
+                ((themes '(("Bibata-Modern-Amber" . "Yellowish and rounded")
+                           ("Bibata-Modern-Classic" . "Black and rounded")
+                           ("Bibata-Modern-Ice" . "White and rounded")
+                           ("Bibata-Original-Amber" . "Yellowish and sharp")
+                           ("Bibata-Original-Classic" . "Black and sharp")
+                           ("Bibata-Original-Ice" . "White and sharp"))))
+              (define theme
+                (car themes))
+              (invoke #$(file-append python-clickgen "/bin/ctgen")
+                      (string-append #$source "/build.toml")
+                      "-p" "x11"
+                      "-d" (string-append #$source "/bitmaps/" (car theme))
+                      "-n" (car theme)
+                      "-c" (string-append (cdr theme) " edge Bibata cursors")
+                      "-o" themes-dir)
+              (unless (null? (cdr themes))
+                (loop (cdr themes))))))))
+    (home-page "https://github.com/ful1e5/Bibata_Cursor")
+    (synopsis "Open-source, compact, and material-designed cursor set")
+    (description
+     "Bibata is an open-source, compact, and material designed
+cursor set.  This project aims at improving the cursor experience.")
+    (license license:gpl3)))
+
 (define-public gnome-plots
   (package
     (name "gnome-plots")
@@ -1690,7 +1738,7 @@  (define-public yaru-theme
  sound themes.
 @end itemize")
     (license (list license:lgpl2.1 license:lgpl3 license:cc-by-sa4.0))))
-  
+
 (define-public nordic-theme
   (let ((commit "07d764c5ebd5706e73d2e573f1a983e37b318915")
 	(revision "0"))