diff mbox series

[bug#62166,1/2] gnu: Add python-clickgen.

Message ID c5b992ab9ebcab464b5f30544c7fb782d94c562f.1678732846.git.contact@conses.eu
State New
Headers show
Series [bug#62166,1/2] gnu: Add python-clickgen. | expand

Commit Message

Miguel Ángel Moreno March 13, 2023, 6:41 p.m. UTC
* gnu/packages/python-xyz.scm (python-clickgen): New variable.
---
 gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Andrew Tropin March 22, 2023, 7:50 a.m. UTC | #1
On 2023-03-13 19:41, conses wrote:

> * gnu/packages/python-xyz.scm (python-clickgen): New variable.
> ---
>  gnu/packages/python-xyz.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 83f3ec02ea..10c2ca3019 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -3802,6 +3802,28 @@ (define-public python-click-7
>          (base32 "06kbzd6sjfkqan3miwj9wqyddfxc2b6hi7p5s4dvqjb3gif2bdfj"))))
>      (arguments `())))
>  
> +(define-public python-clickgen
> +  (package
> +    (name "python-clickgen")
> +    (version "2.1.3")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "clickgen" version))
> +              (sha256
> +               (base32
> +                "010j9zz0gd2za5l4hibicypnfw721x0gxp3rr0329bc97vw5maha"))))
> +    (build-system python-build-system)
> +    (propagated-inputs
> +     (list python-pillow python-toml python-numpy-next python-attrs))
> +    (inputs (list libx11 libpng libxcursor))
> +    (native-inputs (list python-setuptools python-wheel))

Removed python-setuptools from inputs.

> +    (home-page "https://github.com/ful1e5/clickgen")
> +    (synopsis "The hassle-free cursor building toolbox")
> +    (description
> +     "clickgen is an API for building X11 and Windows cursors from .png files.

Capitalized the description.

> +clickgen is using @code{anicursorgen} and @code{xcursorgen} under the hood.")
> +    (license license:expat)))
> +
>  (define-public python-cligj
>    (package
>      (name "python-cligj")
> -- 
> 2.39.1

Thank you for the patch, applied.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83f3ec02ea..10c2ca3019 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3802,6 +3802,28 @@  (define-public python-click-7
         (base32 "06kbzd6sjfkqan3miwj9wqyddfxc2b6hi7p5s4dvqjb3gif2bdfj"))))
     (arguments `())))
 
+(define-public python-clickgen
+  (package
+    (name "python-clickgen")
+    (version "2.1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "clickgen" version))
+              (sha256
+               (base32
+                "010j9zz0gd2za5l4hibicypnfw721x0gxp3rr0329bc97vw5maha"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-pillow python-toml python-numpy-next python-attrs))
+    (inputs (list libx11 libpng libxcursor))
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://github.com/ful1e5/clickgen")
+    (synopsis "The hassle-free cursor building toolbox")
+    (description
+     "clickgen is an API for building X11 and Windows cursors from .png files.
+clickgen is using @code{anicursorgen} and @code{xcursorgen} under the hood.")
+    (license license:expat)))
+
 (define-public python-cligj
   (package
     (name "python-cligj")