diff mbox series

[bug#67190,6/6] * gnu/packages/vim.scm (vim-plantuml-syntax): New variable

Message ID 3eff0346b009e2da5e2b9a39280913fb90df6a26.1700006719.git.nathanmerkley@gmail.com
State New
Headers show
Series *** Add vim plugins *** | expand

Commit Message

Nathan Merkley Nov. 15, 2023, 12:21 a.m. UTC
Change-Id: I3e116520239bb66b1140e5bbd40659b3681f77e6
---
 gnu/packages/vim.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 054c23bc92..7886f63e97 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1562,3 +1562,32 @@  (define-public vim-zig
 language.")
       (home-page "https://github.com/ziglang/zig.vim")
       (license license:expat))))
+
+(define-public vim-plantuml-syntax
+  (let ((commit "845abb56dcd3f12afa6eb47684ef5ba3055802b8")
+        (revision "1"))
+    (package
+      (name "vim-plantuml-syntax")
+      (version (string-append "0.0.0-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/aklt/plantuml-syntax")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32 "0d2frv6knkj4bjavq2c2kx8qdnmcq0d8l04a5z7bpqwkmrrhd31f"))))
+      (build-system vim-build-system)
+      (arguments
+       (list
+        #:plugin-name "plantuml-syntax"))
+      (synopsis "Syntax highlighting for PlantUML")
+      (description
+       "This is a vim syntax file for PlantUML.  The filetype will be set to
+plantuml for *.pu, *.uml, *.puml, *.iuml or *.plantuml files or if the first
+line of a file contains @@startuml.  Additionally the makeprg is set to plantuml
+assuming you have this executable in your path.")
+      (home-page "https://github.com/aklt/plantuml-syntax")
+      (license license:vim))))