diff mbox series

[bug#67188,2/6] * gnu/packages/vim.scm (vim-guile): New variable

Message ID 2b6a3e5c57dda4ad32dec18810c0a57b42f6bdb9.1700006719.git.nathanmerkley@gmail.com
State New
Headers show
Series *** Add vim plugins *** | expand

Commit Message

Nathan Merkley Nov. 15, 2023, 12:21 a.m. UTC
Change-Id: I2f69a563681693de9af563caa545f6421f61a093
---
 gnu/packages/vim.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d0877033b9..38e651388f 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1454,3 +1454,32 @@  (define-public vim-commentary
 :g/TODO/Commentary.")
       (home-page "https://www.vim.org/scripts/script.php?script_id=3695")
       (license license:vim))))
+
+(define-public vim-guile
+  (let ((commit "f76959a9dbdc69cde018901de82ac5a3d443843c")
+        (revision "1"))
+    (package
+      (name "vim-guile")
+      (version (string-append "0.0.0-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/HiPhish/guile.vim")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32 "1pqlhssdnpd8ngjc5bssma7ddjhffvh8hj67gchmyyxr5jfxwdq9"))))
+      (build-system vim-build-system)
+      (arguments
+       (list
+        #:plugin-name "guile.vim"))
+      (synopsis "Syntax highlighting for GNU Guile")
+      (description
+       "This plugin extends Vim's Scheme support to include the additions to
+the language provided by the GNU Guile implementation.  The plugin automatically
+detects whether a Scheme file is a Guile file and adds syntax highlighting for
+Guile's special forms.")
+      (home-page "https://github.com/HiPhish/guile.vim")
+      (license license:expat))))