[bug#77488] gnu: emacs-forge: Update to 0.5.0.

Message ID 3ebf657308e2dff942e121c5d7a6eeaa0bb9fb59.1743682009.git.csantosb@inventati.org
State New
Headers
Series [bug#77488] gnu: emacs-forge: Update to 0.5.0. |

Commit Message

Cayetano Santos April 3, 2025, 12:06 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-forge): Update to 0.5.0.

Change-Id: I188508fd234b2b3081aed11026b4f2a83588febb
---

Update to 5.0, and fixes indentation too.

 gnu/packages/emacs-xyz.scm | 79 +++++++++++++++++++-------------------
 1 file changed, 40 insertions(+), 39 deletions(-)


base-commit: c6d27c20f4685a9ac1299974f6ace42ae29f474d
--
2.49.0
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e30989cb1e..894ce4efe4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -34284,46 +34284,47 @@  (define-public emacs-transient
 
 (define-public emacs-forge
   (package
-     (name "emacs-forge")
-     (version "0.4.8")
-     (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-              (url "https://github.com/magit/forge")
-              (commit (string-append "v" version))))
-        (file-name (git-file-name name version))
-        (sha256
-         (base32 "1ps1xwpxhb9vn6bf0wxy8bdba72f973spys0xw1k686swczrb225"))))
-     (build-system emacs-build-system)
-     (arguments
-      `(#:tests? #f                     ;no tests
-        #:phases
-        (modify-phases %standard-phases
-          (add-after 'unpack 'build-info-manual
-            (lambda _
-              (invoke "make" "info")
-              ;; Move the info file to lisp so that it gets installed by the
-              ;; emacs-build-system.
-              (rename-file "docs/forge.info" "lisp/forge.info")))
-          (add-after 'build-info-manual 'chdir-lisp
-            (lambda _
-              (chdir "lisp"))))))
-     (native-inputs
-      (list texinfo))
-     (propagated-inputs
-      (list emacs-closql
-            emacs-emacsql
-            emacs-ghub
-            emacs-let-alist
-            emacs-magit
-            emacs-markdown-mode
-            emacs-yaml))
-     (home-page "https://github.com/magit/forge/")
-     (synopsis "Access Git forges from Magit")
-     (description "Work with Git forges, such as Github and Gitlab, from the
+    (name "emacs-forge")
+    (version "0.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/magit/forge")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "02ks8zc3nqqqqfq2picf0pxsw7wygb5hv9abnva1cv44x091w6zw"))))
+    (build-system emacs-build-system)
+    (arguments
+     `(#:tests? #f                     ;no tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'build-info-manual
+           (lambda _
+             (invoke "make" "info")
+             ;; Move the info file to lisp so that it gets installed by the
+             ;; emacs-build-system.
+             (rename-file "docs/forge.info" "lisp/forge.info")))
+         (add-after 'build-info-manual 'chdir-lisp
+           (lambda _
+             (chdir "lisp"))))))
+    (native-inputs
+     (list texinfo))
+    (propagated-inputs
+     (list emacs-closql
+           emacs-emacsql
+           emacs-ghub
+           emacs-llama
+           emacs-let-alist
+           emacs-magit
+           emacs-markdown-mode
+           emacs-yaml))
+    (home-page "https://github.com/magit/forge/")
+    (synopsis "Access Git forges from Magit")
+    (description "Work with Git forges, such as Github and Gitlab, from the
 comfort of Magit and the rest of Emacs.")
-     (license license:gpl3+)))
+    (license license:gpl3+)))
 
 (define-public emacs-matcha
   (let ((commit "dc4a940b3360aadeb2d9eaab7bd0c85e1e85ab76"))