diff mbox series

[bug#70955,1/6] gnu: Add go-github-com-pion-logging.

Message ID 37d588ce30733b819c15ea39fe1f3863e80538a2.1715753200.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: Add go-github-com-pion-stun-v2 and go-github-com-pion-mdns. | expand

Commit Message

Artyom V. Poptsov May 15, 2024, 6:17 a.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-pion-logging): New variable.

Change-Id: I2da53900059251b78cad2bb56cfbc87228c91e23
---
 gnu/packages/golang-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cd023da86c..4ed310e9ef 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2982,6 +2982,30 @@  (define-public go-github-com-pierrec-cmdflag
 on top of the standard library @code{flag} package.")
     (license license:bsd-3)))
 
+(define-public go-github-com-pion-logging
+  (package
+    (name "go-github-com-pion-logging")
+    (version "0.2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pion/logging/")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11ay8c15xk3pv7y9nd80szk3mci480x67yqlgb10vswrz4h4mx3v"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/pion/logging"))
+    (home-page "https://github.com/pion/logging/")
+    (synopsis "Logging library used by @url{https://github.com/pion, Pion}")
+    (description
+     "he library is used as a part of @url{https://github.com/pion, Pion} WebRTC
+implementation.")
+    (license license:expat)))
+
 (define-public go-github-com-prometheus-client-model
   (package
     (name "go-github-com-prometheus-client-model")