diff mbox series

[bug#67950,v2,2/3] gnu: Add informlib.

Message ID 37765b77-c544-8c9a-d760-899c93ebf2c8@disroot.org
State New
Headers show
Series [bug#67950,v2,1/3] gnu: Add inform. | expand

Commit Message

Adam Faiz Dec. 24, 2023, 3:49 p.m. UTC
From c1fa9c53f3dda536d372257b876918376734b9d5 Mon Sep 17 00:00:00 2001
Message-ID: <c1fa9c53f3dda536d372257b876918376734b9d5.1703432554.git.adam.faiz@disroot.org>
In-Reply-To: <eaf206d6a1a29a2334fa31e9692bf6f584d73409.1703432554.git.adam.faiz@disroot.org>
References: <eaf206d6a1a29a2334fa31e9692bf6f584d73409.1703432554.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 24 Dec 2023 23:14:31 +0800
Subject: [PATCH v2 2/3] gnu: Add informlib.

* gnu/packages/game-development.scm (informlib): New variable.
---
 gnu/packages/game-development.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 72349a8d9b..dec0209d6b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2805,6 +2805,30 @@  (define-public inform
     (home-page "https://jxself.org/git/inform.git")
     (license license:gpl3+)))
 
+(define-public informlib
+  (package
+    (name "informlib")
+    (version "6.12.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://jxself.org/git/informlib.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fcnw4jjzln402qk097n2s8y24vw1p3mmlmh6k1mbr2zfajjcn5r"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:install-plan
+      #~'(("." "lib"))))
+    (synopsis "Inform 6 standard library")
+    (description
+     "This package provides the standard library for Inform 6.")
+    (home-page "https://jxself.org/git/informlib.git")
+    (license license:agpl3+)))
+
 (define-public instead
   (package
     (name "instead")