diff mbox series

[bug#67950,v2,1/3] gnu: Add inform.

Message ID 2ae87a7c-ae7c-28fd-b6ae-14d3f87d39e5@disroot.org
State New
Headers show
Series [bug#67950,v2,1/3] gnu: Add inform. | expand

Commit Message

Adam Faiz Dec. 24, 2023, 3:46 p.m. UTC
From eaf206d6a1a29a2334fa31e9692bf6f584d73409 Mon Sep 17 00:00:00 2001
Message-ID: <eaf206d6a1a29a2334fa31e9692bf6f584d73409.1703432554.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 21 Dec 2023 18:15:41 +0800
Subject: [PATCH v2 1/3] gnu: Add inform.

* gnu/packages/game-development.scm (inform): New variable.
---
 gnu/packages/game-development.scm | 34 +++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 29c94dd522833b2603a651c14a5b06120bcf1829
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index a2d7c5ea63..72349a8d9b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2771,6 +2771,40 @@  (define-public ioquake3
 people base their games, ports to new platforms, and other projects.")
       (license license:gpl2))))
 
+(define-public inform
+  (package
+    (name "inform")
+    (version "6.41")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://jxself.org/git/inform.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1g2misbp4lacaqa96wk0ad59ybr2dvjnhjsrz98byx4i99s2m2nr"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 'build
+            (lambda _
+              (apply invoke #$(cc-for-target) "-o" "inform"
+                     (find-files "src" "\\.c$")))))
+      #:install-plan
+      #~'(("inform" "bin/inform"))))
+    (native-inputs (list autoconf automake))
+    (synopsis "The Inform 6 compiler")
+    (description
+     "Inform 6 is a C-like programming language designed
+for interactive fiction.  This version of the compiler has been modified
+slightly to work better when the Inform standard library is in a non-standard
+location.")
+    (home-page "https://jxself.org/git/inform.git")
+    (license license:gpl3+)))
+
 (define-public instead
   (package
     (name "instead")