diff mbox series

[bug#70563] gnu: Add pkcs11-helper.

Message ID 356e77d1fbad51a042ebb8eaae2804bb74a30c9b.1714036907.git.atai@atai.org
State New
Headers show
Series [bug#70563] gnu: Add pkcs11-helper. | expand

Commit Message

Andy Tai April 25, 2024, 9:22 a.m. UTC
* gnu/packages/security-token.scm (pkcs11-helper): New variable.

Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
---
 gnu/packages/security-token.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 4514239971895fc7ad47c7752e30d98a0c44a154

Comments

Andy Tai April 30, 2024, 7:21 p.m. UTC | #1
patch passed QA
https://qa.guix.gnu.org/issue/70563
Andy Tai May 2, 2024, 9:21 p.m. UTC | #2
patch passed QA

https://qa.guix.gnu.org/issue/70563
diff mbox series

Patch

diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 00a7f97582..5e20424001 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -394,6 +394,30 @@  (define-public opensc
 #15 standard and the PKCS #11 API.")
     (license license:lgpl2.1+)))
 
+
+(define-public pkcs11-helper
+  (package
+    (name "pkcs11-helper")
+    (version "1.30.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
+             version "/pkcs11-helper-" version ".tar.bz2"))
+       (sha256
+        (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
+    (build-system gnu-build-system)
+    (inputs (list openssl-1.1 pcsc-lite))
+    (native-inputs (list pkg-config))
+    (home-page "https://github.com/OpenSC/pkcs11-helper")
+    (synopsis "Library that simplifies the interaction with PKCS#11 providers")
+    (description
+     "Pkcs11-helper is a library that simplifies the interaction with
+PKCS#11 providers for end-user applications")
+    (license (list license:gpl2 license:bsd-3))))
+
+
 (define-public yubico-piv-tool
   (package
     (name "yubico-piv-tool")